For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Yamaha: Boosted Sleds (Turbo or Supercharged) Turbo discussion for Yamaha aftermarket Turbo or Super Charged sleds.
Reply
 
Share Thread Tools Display Modes
  #1  
Old 05-22-2017, 06:36 PM
madsledder madsledder is offline
Currently: Not set.
Join Date: Feb 2008
Location: Creston B.C.
Basic Member
Posts: 555
Thanks: 54
Thanked 40 Times in 35 Posts
Rep Power: 1860375
madsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond repute
Default mpi turbo not boosting at altitude

Did have a thread but starting a new one because its not backwards its just not boosting at altitude. Yes I have contacted mpi and dealt with them. 2015 Yamaha viper mtx 190 kit. So far no boost leaks, eabc and gems has been tested. Turbo has been tested and run on another sled. I bought a new map sensor and seemed to work for a bit but now same as the other one. I finally got to test at 6500'-7000' and only 4-5 psi. It doesn't over boost after about 5000'. Supposed to the way the eabc works I guess. I'm sure it has something to do with the eabc, map sensor, gems box. Thought it could be a voltage problem? I wont be able to try it again this season but hopefully I can have it figured out for the next one.

Last edited by madsledder; 05-22-2017 at 06:39 PM.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 05-24-2017, 02:31 PM
madsledder madsledder is offline
Currently: Not set.
Join Date: Feb 2008
Location: Creston B.C.
Basic Member
Posts: 555
Thanks: 54
Thanked 40 Times in 35 Posts
Rep Power: 1860375
madsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond reputemadsledder has a reputation beyond repute
Default

Talked to mpi and they think it is because I added an intercooler without the dual port waste gate or having the eabc and gems reprogramed.* It changes a lot and is only beneficial after 7 psi. So I pulled it and now hope to try it again Friday
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Nytro turbo altitude compensator with PCV? Thread Starter — zx4ever Forum — Yamaha: Boosted Sleds (Turbo or Supercharged) Replies — 2 Last Post — 03-27-2016 09:58 AM
Thread — MPI Electronic Altitude Boost Compensation! Thread Starter — Matt@MPI Forum — Vipers! Replies — 9 Last Post — 01-12-2015 05:36 PM
Thread — so who else is boosting their XM??? Thread Starter — stalefish_132 Forum — Ski-Doo: TURBO Replies — 20 Last Post — 01-05-2013 04:08 PM
Thread — Altitude compensator on turbo phazer Thread Starter — putland_22 Forum — Phazers! Replies — 3 Last Post — 03-07-2009 06:57 PM
Thread — MCX Turbo Apex No Boost at Altitude Thread Starter — boostedballz Forum — Yamaha Replies — 11 Last Post — 12-19-2007 01:01 PM

All times are GMT -6. The time now is 08:05 AM.

no new posts