• Don't miss out on all the fun! Register on our forums to post and have added features! Membership levels include a FREE membership tier.

Dead Pro


Well-known member
Lifetime Membership
Jul 6, 2008
Fort St. James, B.C.
I have a 2013 Pro that died on me last week. I took it out of the shop after all summer and it fired right up; let it idle up to temperature and the shut it down. I then went to show (do) my brother in law how to change the fuel filter on his 2013 Pro (its was very restricted). We changed his filter, buttoned it up and moved it back out of the shop. I went to start up my 2013; it fired Up and ran for 2 seconds and died; I could not get another pop out of it. I swapped plugs and no go; the PTO plug was wet and the Mag plug dry.
I tried a couple more times later in the day but no difference; we just pushed it back into the shop.
I put new plugs in yesterday; no go.
Checked electrical connections; no go.
Swapped capacitor and voltage regulator off my 2014 Assault; no go.
Finally to narrow it down; I put an oil cap full of fuel down into each cylinder to see if it would start; it fired up and shut down.
Thinking it had burned the fuel off; I tried pulling it once more for the heck of it and it fired right up and ran fine…
I tried shutting it down and starting it several times and now no issues..
So, I’m thinking I had a vapour lock after all summer..
Anyone ever ran into this scenario??
Just wanted to post this in case someone runs into something similar in the future.
Premium Features