For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: TURBO Turbo discussion for Polaris aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 04-29-2019, 02:49 PM
Mtnsledder65 Mtnsledder65 is offline
Currently: Not set.
Join Date: Mar 2019
Basic Member
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Mtnsledder65 is an unknown quantity at this point
Default 15 pro 800 silber turbo

I swapped a silber external wastegate turbo kit with reflashed ecu. The other the sled I put to stock seems to run fine but mine with turbo wont fire and when it does it dies immediately or will idle too high and die if you touch the throttle like hitting the kill switch. I dont think it's the throttle safety switch as I used a resistor plug that bypasses it for a munster throttle. I swapped obviously the exhaust, air box injectors map sensor coolant hose clutching the hoses in the tank oil lines and the ECU. I dont know if I've missed something as the instructions on silbers website and the one or two videos I saw are different setups. I've taken to the dealer to have it scanned nothing came up and tps seemed fine. I've emailed silber multiple times but the most I got back was have you had it scanned by a dealer. Any suggestions would be greatly appreciated as I dont trust any of the three closest dealers to touch my sled after previous experiences.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 04-30-2019, 05:33 PM
willjogervais willjogervais is offline
Currently: Not set.
Join Date: Mar 2011
Location: SW Minnesota
Age: 39
Posts: 430
Thanks: 183
Thanked 154 Times in 84 Posts
Rep Power: 15803047
willjogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond repute
Default

were the sled's the same year that you swapped ecu's? There is a sticker on the ecu which states what color injectors it is programmed for, make sure that the new sled has the correct color injectors for the ecu.


Edit- I just saw that this is for a '15, I'm not sure if they have different injectors like the axys.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 04-30-2019, 10:35 PM
05rmksteve's Avatar
05rmksteve 05rmksteve is online now
Currently: Putting sleds together
Join Date: Sep 2008
Location: Brainerd, MN
Age: 45
Posts: 1,423
Thanks: 91
Thanked 394 Times in 242 Posts
Rep Power: 21474848
05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute
Default

Check all wiring connectors, check the pins on the ecu make sure theres no bent ones. Swap ecu with the running sled see if the sled will run with the other ecu in it. 13-15 ECU's are interchangeable with the turbo set up just need to have them flashed for proper injector color and turbo. There isnt really anything with the turbo except the ecu that would cause the sled to not run.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — '14 rmk pro 800 silber turbo with ecu Thread Starter — t30mg Forum — Turbos/Superchargers (Swapmeet) Replies — 3 Last Post — 08-30-2018 12:34 AM
Thread — 2014 Pro 800 silber turbo Thread Starter — "Back in Black" Forum — Polaris (Swapmeet) Replies — 0 Last Post — 11-08-2016 05:51 PM
Thread — '12 Pro RMK 800 Silber Turbo Thread Starter — summit_man Forum — Polaris (Swapmeet) Replies — 2 Last Post — 11-08-2016 03:15 PM
Thread — 2 12 polaris pro rmk 800 silber turbo Thread Starter — purepolaris600 Forum — Polaris (Swapmeet) Replies — 0 Last Post — 08-17-2016 07:00 PM
Thread — 2013 800 pro /Silber turbo need some help Thread Starter — summit800 Forum — Polaris: TURBO Replies — 34 Last Post — 01-28-2016 12:23 PM

All times are GMT -6. The time now is 09:37 PM.








no new posts