For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: Powder Special and older 2000 and older, all models in the Powder Special chassis and older chassis models
Reply
 
Share Thread Tools Display Modes
  #1  
Old 02-13-2014, 07:24 AM
Jamesh11 Jamesh11 is offline
Currently: Not set.
Join Date: Nov 2013
Basic Member
Posts: 57
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 534190
Jamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond repute
Default Kitty 120 question

Posting this here because I know people here know the answer :-)

My blackmagic kitty 120 just died the other day after running nicely for over an hour. It refused to fire up after 20 million pulls. Plug was fouled so I replaced it. It fired right up and idled nicely.

Fired it up last night and let it warm up for 5 minutes. I noticed that the headlight didn't come on but the tail light did. My boy got on, drove 25 feet and it died. I couldn't get it to fire up for the life of me....another 20 million pulls.

I pulled the plug wire and stuck my little finger down into it as I pulled the rope and didn't get a shock.....yes I know, but I wanted to know :-))

I figure voltage regulator and maybe ignition spark control module?? Either or? It's clearly an electrical issue.

Just want some thoughts from those who have experience. I know that catman knows :-)))
Reply With Quote


Rate this post: Yes | No
  #2  
Old 02-13-2014, 08:00 AM
Jamesh11 Jamesh11 is offline
Currently: Not set.
Join Date: Nov 2013
Basic Member
Posts: 57
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 534190
Jamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond repute
Default

Have to clarify that it will fire up intermittently if I struggle with it long enough, but then die intermittently as well.

Something seems to expand and contract under heat and cold as it has worn out. The kitty is an '03.

I took off the carb bracket last week when it broke off and welded it back together. I may have inadvertently plucked on a connector of sorts in the process of taking off and replacing the bracket.

Last edited by Jamesh11; 02-13-2014 at 08:02 AM.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 02-13-2014, 12:06 PM
Jamesh11 Jamesh11 is offline
Currently: Not set.
Join Date: Nov 2013
Basic Member
Posts: 57
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 534190
Jamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond repute
Default

How do I check if the stator is functioning except for sticking my little finger in the plug wire?
Reply With Quote


Rate this post: Yes | No
  #4  
Old 02-20-2014, 05:27 AM
Jamesh11 Jamesh11 is offline
Currently: Not set.
Join Date: Nov 2013
Basic Member
Posts: 57
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 534190
Jamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond reputeJamesh11 has a reputation beyond repute
Default

Update:

I have it figured out and it's a weird one.

There is for some reason a reverse loop through the headlight bulb. When that gets broken the engine will not start and run. My headlight bulb looked fine to the eye but when I took it out and tested it it was blown. Voltage regulator was good. With the headlight bulb blown there was no spark either which sent me on a fruitless wild goose chase.

I replaced the headlight bulb in desperation just to start fixing what I knew was broken and she has been running fine ever since.....

These darn machines are just like women....they do weird stuff for no rhyme nor reason and make you pull the hair out of your own head trying to figure out what is either wrong or what you have done wrong. Then with some seemingly foolish little adjustment they are happy as ever for another little while...
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Kitty 120 dying intermittently Thread Starter — Jamesh11 Forum — Youth Sleds Replies — 0 Last Post — 02-12-2014 06:25 PM
Thread — Kitty cat or 120 Thread Starter — wyogeorge Forum — Youth Sleds Replies — 5 Last Post — 11-11-2012 07:40 PM
Thread — looking for a small sled KITTY KAT, XC 120, MINI Z Thread Starter — ARMYSLEDER Forum — Arctic Cat (Swapmeet) Replies — 4 Last Post — 12-21-2007 08:38 AM
Thread — looking for a small sled KITTY KAT, XC 120, MINI Z Thread Starter — ARMYSLEDER Forum — Ski-Doo (Swapmeet) Replies — 4 Last Post — 12-11-2007 08:22 AM
Thread — looking for a small sled KITTY KAT, XC 120, MINI Z Thread Starter — ARMYSLEDER Forum — Polaris (Swapmeet) Replies — 5 Last Post — 12-11-2007 07:58 AM

All times are GMT -6. The time now is 08:05 PM.

no new posts