For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Ski-Doo: REV Sleds 2004.5-200, all models in the REV chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 01-19-2018, 10:54 AM
Aksnowman89 Aksnowman89 is offline
Currently: Not set.
Join Date: Dec 2017
Basic Member
Age: 28
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Aksnowman89 is an unknown quantity at this point
Default Bogging issue

My brother and I are having an issue that we've been dealing with for the past couple seasons. He has a 2004 MXZ Renegade 800 HO that wont run properly. The issue is that the sled seems to run fine for a little while until we start getting into the deeper stuff.

The sled will just start running like garbage. It wont get over 5.5-6k on RPMs. It sounds like a serious bog issue.

The things we've replaced are:
-top end
-rebuilt crank
-carb face gasket
-rebuilt primary clutch
-coil pack
-carb boots
-Y pipe gaskets
-spark plugs
-belt

We've run out of ideas and any advice would help. Again, after we've done the work and "think" we've fixed the issue it runs fine just running up and down the road. It tacks properly and runs like a raped ape. Also going down the trail to get to our favorite spots, it runs fine. After a while of riding and playing around in the deeper snow it falls on its face.

Thanks for the help.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 01-19-2018, 04:47 PM
Ox's Avatar
Ox Ox is offline
Currently: New sled and ready to roll!
Join Date: Jul 2001
Location: NW Ohio
Age: 51
Posts: 740
Thanks: 16
Thanked 52 Times in 45 Posts
Rep Power: 5843715
Ox has disabled reputation
Default

A) Prefilters on your air intake(s)?
Does it only happen in the powder?

B) You say that you have done some work on your primary, but how about your secondary clutch?

C) Since you are on Snowest, I hafta ask if possibly you changed the track? If you are trying to pull a 151 x 2 with Revnegade gears - that will produce bog too.




I'm leaning towards the secondary clutch...


.
__________________
Looks like I lost my old post count ... AGAIN....
Hey - it was a good run while it lasted...

Ask me about aftermarket Doo recoils.

Life Insurance
Death Insurance
Reply With Quote


Rate this post: Yes | No
  #3  
Old 01-23-2018, 11:52 AM
BBP BBP is offline
Currently: Not set.
Join Date: Sep 2009
Location: Yakima Wa
Basic Member
Posts: 410
Thanks: 101
Thanked 52 Times in 38 Posts
Rep Power: 1242854
BBP has a reputation beyond reputeBBP has a reputation beyond reputeBBP has a reputation beyond reputeBBP has a reputation beyond reputeBBP has a reputation beyond reputeBBP has a reputation beyond reputeBBP has a reputation beyond reputeBBP has a reputation beyond reputeBBP has a reputation beyond reputeBBP has a reputation beyond reputeBBP has a reputation beyond repute
Default

When you rebuilt the primary clutch, did you install a new sliding sheave bushing? If that bushing is bad, it will fall on it's face under load. Does the problem get worse at higher altitude? If so, it could be a DPM problem.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — bogging issue Thread Starter — tbeaton Forum — Polaris: AXYS Replies — 21 Last Post — 03-29-2016 11:16 AM
Thread — Bogging issue Thread Starter — Rmknewf Forum — Polaris: Pro-Ride Replies — 2 Last Post — 02-01-2016 11:04 PM
Thread — Another bogging issue! Thread Starter — roppin Forum — Polaris: Pro-Ride Replies — 54 Last Post — 03-09-2013 05:41 PM
Thread — Strange Low Temp issue bogging issue... Thread Starter — Shum Forum — Polaris: 900 Replies — 3 Last Post — 12-27-2011 11:39 PM
Thread — Bogging issue Thread Starter — leadropr Forum — Arctic Cat: M Series Replies — 6 Last Post — 03-29-2011 08:12 PM

All times are GMT -6. The time now is 05:51 PM.

no new posts