Nytro Powerlites

Sep 28, 2009
28
2
3
Boise, Id
Im having trouble with my 2008 Powderlites turbo sled. It wont start or run. Snake River Yamaha told me the problem is with the Rapid Bike 3 controller but says that part is not available anymore. Anyone run into this problem?
 
Oct 9, 2009
170
112
43
Did you try a new battery? It wont fire the coils if the voltage is too low. Most dealers cannot diag a controller. Usually, it is a..."we tried everything else, so it has to be that controller." It could be, but it may not be. I would also check your fuse box and look for blown starter relays or fuse. Ask the dealer if they reviewed all the circuits. Also, look over all the ground wires on your sled. It wont fire if there is a corroded ground wire. If you own a turbo, I suggest getting use to working on a few items. They are mechanically very reliable, but every once and a while you may have a weird wiring issue. I have personally had wires become brittle because of engine bay heat and break internally, causing a no start issue. The dealer found the wire and fixed it for me. The rest I do myself.
 

motojunkie101

MODERATOR: Premium Member
Nov 26, 2007
2,252
761
113
37
Honolulu, Hawaii
I'm not super familiar with the RB3, but if it is a piggy back fuel controller, you can just remove it from the system, plug the stock harness back together and see if your sled starts. Don't rev it up or anything, if your sled builds boost a lot of bad things will happen without the extra fuel...but at idle and zero boost you'll be fine for a test fire.
 
Premium Features