For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Ski-Doo: TURBO Turbo discussion for Ski-Doo aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 12-30-2017, 11:02 AM
Chadly's Avatar
Chadly Chadly is offline
Currently: Not set.
Join Date: Aug 2013
Location: Bothell, WA
Posts: 840
Thanks: 130
Thanked 691 Times in 282 Posts
Rep Power: 21474842
Chadly has disabled reputation
Default Engine Faults with MPI kit...

Every now and then I'm getting the Over Rev followed instantly by the knock message on the display on my sled. I am resetting the max rpm gauge everytime and the highest RPM I have seen is 7900 rpm so there is no way it's over revving per the gauge. Running straight 100 octane so knock seems unrealistic as well. Wondering if an over fueling issue would cause these faults because it sure seems like its running rich...
Reply With Quote


Rate this post: Yes | No
  #2  
Old 12-31-2017, 08:18 AM
snoblind04's Avatar
snoblind04 snoblind04 is offline
Currently: having a blast on my mpi turbo
Join Date: Nov 2007
Location: Western Wyoming
Posts: 227
Thanks: 5
Thanked 34 Times in 28 Posts
Rep Power: 1500941
snoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond repute
Default

I've been running with about a gallon of 110 per tank in mine. No issues yet but I only have two rides so far.
Reply With Quote


1 out of 1 members found this post helpful. Rate this post: Yes | No
  #3  
Old 01-11-2018, 11:41 PM
madmax's Avatar
madmax madmax is offline
Currently: Not set.
Join Date: Nov 2007
Posts: 3,224
Thanks: 13
Thanked 1,435 Times in 592 Posts
Rep Power: 21474850
madmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond repute
Default

Quote:
Originally Posted by Chadly View Post
Every now and then I'm getting the Over Rev followed instantly by the knock message on the display on my sled. I am resetting the max rpm gauge everytime and the highest RPM I have seen is 7900 rpm so there is no way it's over revving per the gauge. Running straight 100 octane so knock seems unrealistic as well. Wondering if an over fueling issue would cause these faults because it sure seems like its running rich...
How often you getting the knock code?
Reply With Quote


Rate this post: Yes | No
  #4  
Old 01-12-2018, 07:32 AM
winter brew's Avatar
winter brew winter brew is online now
Currently: Not set.
Join Date: Nov 2007
Location: LakeTapps, Wa.
Premium Member
Age: 50
Posts: 9,915
Thanks: 1,499
Thanked 2,914 Times in 1,599 Posts
Rep Power: 21474856
winter brew has a reputation beyond reputewinter brew has a reputation beyond reputewinter brew has a reputation beyond reputewinter brew has a reputation beyond reputewinter brew has a reputation beyond reputewinter brew has a reputation beyond reputewinter brew has a reputation beyond reputewinter brew has a reputation beyond reputewinter brew has a reputation beyond reputewinter brew has a reputation beyond reputewinter brew has a reputation beyond repute
Default

Over rev can also be triggered when the rate of RPM increase is too quick. loading the primary quicker/harder takes care of that.
Reply With Quote


2 out of 2 members found this post helpful. Rate this post: Yes | No
The Following User Says Thank You to winter brew For This Useful Post:
mountainhorse (01-13-2018)
  #5  
Old 01-12-2018, 03:29 PM
ghost rider ghost rider is online now
Currently: videos
Join Date: Dec 2007
Age: 42
Posts: 635
Thanks: 66
Thanked 204 Times in 78 Posts
Rep Power: 0
ghost rider has a reputation beyond reputeghost rider has a reputation beyond reputeghost rider has a reputation beyond reputeghost rider has a reputation beyond reputeghost rider has a reputation beyond reputeghost rider has a reputation beyond reputeghost rider has a reputation beyond reputeghost rider has a reputation beyond reputeghost rider has a reputation beyond reputeghost rider has a reputation beyond reputeghost rider has a reputation beyond repute
Default Mpi

Quote:
Originally Posted by winter brew View Post
Over rev can also be triggered when the rate of RPM increase is too quick. loading the primary quicker/harder takes care of that.
As stated above is probably what's happening. Happened to me last year a few times when the track came unloaded. I started last year with ski doo clutch components(only thing out there) and even tho I loaded it heavier with heavier ramp and heavier spacers it happened occasionally. I run 2 gallons of Av per tank and good non ethanol 93. This year I switched to sled head racing ramps(full clutch kit)loaded all the way and number 3 spacer weight, clicker 2 at 7-10,000 ft. I'm running around 8-8100 rpm at all elevations and conditions, up 4-5mph track speed to 52mph from 47ish. No blown belts and cooler clutch temps. Im at over 1000 miles on kit and in my opinion the best setup I've rode or ride with. Everyone can talk about how there turbo kit has ecu programmed or run a piggy back controller etc but if you don't have your clutching dialed it's all for not. Then you have the blend of fuel to deal with as well. To much race or Av and it feels lazy and rich and response goes to crap(once again doesn't matter which kit you have whether piggy back or programmed ecu) to little and you burn it down. I have no affiliation with any product manufacturer and have ran all there kits in the past. Loving my mpi 850
Reply With Quote


1 out of 1 members found this post helpful. Rate this post: Yes | No
  #6  
Old 01-12-2018, 10:14 PM
fredw fredw is offline
Currently: 850 blown up before Breakin over
Join Date: Nov 2007
Location: medicine hat
Basic Member
Age: 50
Posts: 2,417
Thanks: 446
Thanked 373 Times in 244 Posts
Rep Power: 21211995
fredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond repute
Default

Another idea to slow burn rate of fuel is add a degree or two of timing, I have just done that and it has picked up on response
Reply With Quote


Rate this post: Yes | No
  #7  
Old 01-13-2018, 09:54 AM
pepperhouse pepperhouse is offline
Currently: Not set.
Join Date: Jan 2010
Posts: 26
Thanks: 3
Thanked 3 Times in 3 Posts
Rep Power: 0
pepperhouse has a reputation beyond reputepepperhouse has a reputation beyond reputepepperhouse has a reputation beyond reputepepperhouse has a reputation beyond reputepepperhouse has a reputation beyond reputepepperhouse has a reputation beyond reputepepperhouse has a reputation beyond reputepepperhouse has a reputation beyond reputepepperhouse has a reputation beyond reputepepperhouse has a reputation beyond reputepepperhouse has a reputation beyond repute
Default

Quote:
Originally Posted by ghost rider View Post
As stated above is probably what's happening. Happened to me last year a few times when the track came unloaded. I started last year with ski doo clutch components(only thing out there) and even tho I loaded it heavier with heavier ramp and heavier spacers it happened occasionally. I run 2 gallons of Av per tank and good non ethanol 93. This year I switched to sled head racing ramps(full clutch kit)loaded all the way and number 3 spacer weight, clicker 2 at 7-10,000 ft. I'm running around 8-8100 rpm at all elevations and conditions, up 4-5mph track speed to 52mph from 47ish. No blown belts and cooler clutch temps. Im at over 1000 miles on kit and in my opinion the best setup I've rode or ride with. Everyone can talk about how there turbo kit has ecu programmed or run a piggy back controller etc but if you don't have your clutching dialed it's all for not. Then you have the blend of fuel to deal with as well. To much race or Av and it feels lazy and rich and response goes to crap(once again doesn't matter which kit you have whether piggy back or programmed ecu) to little and you burn it down. I have no affiliation with any product manufacturer and have ran all there kits in the past. Loving my mpi 850
Happy to hear your mpi kit is working for you, tried to go that way but got tired of waiting and jumped on a silber kit.

When you say fully loaded with shr clutch kit does that mean your running the 5gram tungsten and 3gram set screw, 8gram total tip weight?

Which pivot bolt are you using?
The stock one or the 4 gram one in kit

Anyone on here have a weight for stock pivot bolt?
Reply With Quote


Rate this post: Yes | No
  #8  
Old 01-13-2018, 08:52 PM
snoblind04's Avatar
snoblind04 snoblind04 is offline
Currently: having a blast on my mpi turbo
Join Date: Nov 2007
Location: Western Wyoming
Posts: 227
Thanks: 5
Thanked 34 Times in 28 Posts
Rep Power: 1500941
snoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond reputesnoblind04 has a reputation beyond repute
Default

I just weighted my stock bolt at 15.4 grams last years was about 17 grams.

I've got over 250 miles on my MPI turbo and it has run great, no codes or anything. I've run some pretty tuff snow and it has not missed a beat. Very happy so far.

I also switched to straight pump gas and I think it runs better than
Reply With Quote


Rate this post: Yes | No
The Following 2 Users Say Thank You to snoblind04 For This Useful Post:
fredw (01-13-2018), pepperhouse (01-14-2018)
  #9  
Old 01-21-2018, 04:25 PM
rmk all the way rmk all the way is offline
Currently: Boost in progress!
Join Date: Nov 2007
Location: Dayton Wa
Age: 28
Posts: 621
Thanks: 70
Thanked 119 Times in 87 Posts
Rep Power: 8968406
rmk all the way has a reputation beyond reputermk all the way has a reputation beyond reputermk all the way has a reputation beyond reputermk all the way has a reputation beyond reputermk all the way has a reputation beyond reputermk all the way has a reputation beyond reputermk all the way has a reputation beyond reputermk all the way has a reputation beyond reputermk all the way has a reputation beyond reputermk all the way has a reputation beyond reputermk all the way has a reputation beyond repute
Default Engine Faults with MPI kit...

I know my 850 absolutely hates having more then about 25 percent av gas and sounds like it’s loading up really bad on the bottom end


Sent from my iPhone using Tapatalk

Last edited by rmk all the way; 01-24-2018 at 08:58 PM.
Reply With Quote


Rate this post: Yes | No
  #10  
Old 01-22-2018, 08:16 AM
Marcusx200 Marcusx200 is offline
Currently: Not set.
Join Date: Nov 2017
Basic Member
Age: 31
Posts: 49
Thanks: 2
Thanked 1 Time in 1 Post
Rep Power: 0
Marcusx200 is an unknown quantity at this point
  #11  
Old 01-22-2018, 09:46 AM
fredw fredw is offline
Currently: 850 blown up before Breakin over
Join Date: Nov 2007
Location: medicine hat
Basic Member
Age: 50
Posts: 2,417
Thanks: 446
Thanked 373 Times in 244 Posts
Rep Power: 21211995
fredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond reputefredw has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

  #12  
Old 01-22-2018, 09:59 AM
Marcusx200 Marcusx200 is offline
Currently: Not set.
Join Date: Nov 2017
Basic Member
Age: 31
Posts: 49
Thanks: 2
Thanked 1 Time in 1 Post
Rep Power: 0
Marcusx200 is an unknown quantity at this point
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

  #13  
Old 01-23-2018, 05:15 PM
madmax's Avatar
madmax madmax is offline
Currently: Not set.
Join Date: Nov 2007
Posts: 3,224
Thanks: 13
Thanked 1,435 Times in 592 Posts
Rep Power: 21474850
madmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond reputemadmax has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Stage 1 upgrade kit for MPI Yamaha 180 kit Thread Starter — Matt@MPI Forum — Yamaha: Boosted Sleds (Turbo or Supercharged) Replies — 26 Last Post — 12-20-2013 11:04 AM
Thread — 1160 Engine tech/1220 CMX 8/900 engine kit for sale Thread Starter — shaun897 Forum — Engine/Engine Parts (Swapmeet) Replies — 2 Last Post — 12-01-2012 10:21 AM
Thread — MPI super charger kit for vector for SALE (complete kit) Thread Starter — turbovector3 Forum — Turbos/Superchargers (Swapmeet) Replies — 0 Last Post — 11-15-2012 12:16 AM
Thread — MM MPI transfer kit?? Thread Starter — thierracing Forum — Yamaha: 2-stroke Replies — 13 Last Post — 11-02-2011 11:20 PM
Thread — My New MPI 180 Kit Thread Starter — stuck a lot Forum — Yamaha: 4-Stroke Replies — 3 Last Post — 12-13-2010 04:52 AM

All times are GMT -6. The time now is 03:54 PM.