For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: 900 05-06 Polaris RMK 900
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-13-2018, 08:35 PM
Snocross111 Snocross111 is offline
Currently: Not set.
Join Date: Mar 2018
Location: NH
Basic Member
Age: 34
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Snocross111 is an unknown quantity at this point
Garage
Default 05 Fusion blinking headlights and cluster

Hey gang, new to the site been reading a lot up on some of the Polaris Fusion 900 issues they have been having from 2005.
I have recently have been chasing an electrical issue with my sled, would be driving along after it’s warmed up at operating temp and the headlights and dash cluster would cut out and not come back on unit I **** the sled off for a couple mins and restart and all would be fine till about 10 mins later it would do it again and again, rinse repeat. Sled never just down or loss power the hole time it did this. I brought it to the dealer and they found flywheel chaffed off on a brown wire, made a repair didn’t fix the problem and was told the regulator was fried. Replaced the regulator and sled fired up but head lights were blinking fast and hole gauge cluster would sweep and blink and at annidle it would say I was doing 25mph, looked over wire harness and found 2 open wires and repaired wires and replaced chassis relay, headlights still flickering and gauge blinks and sweeps but I bring idle up to about 2200rpm it all settles out, on one side of the harness I have 14.2v and up at the headlight connections I only have less then 8v. Before I replaced regulator (Twice) I had 13.8v-14v at headlight connections. Brought it back to the dealer and was told the tower on the stator that controls the dash and headlights was burnt out and needs a stator and another dealer tells me I need a capacitor. I NEED HELP....
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Instrument cluster blinking Thread Starter — snowdak Forum — Polaris: IQ Replies — 1 Last Post — 12-24-2016 05:03 PM
Thread — Instrument cluster blinking Thread Starter — snowdak Forum — Polaris: IQ Replies — 0 Last Post — 12-24-2016 10:52 AM
Thread — M headlights the same as Firecat headlights? Thread Starter — tdbaugha Forum — Arctic Cat: M Series Replies — 5 Last Post — 10-23-2011 04:43 PM
Thread — FUSION 900 GUAGE CLUSTER? Thread Starter — ALPINE SPORTS Forum — Polaris: 900 Replies — 1 Last Post — 01-13-2011 02:54 PM
Thread — NEED 04 rev speedo/tach cluster,throttle cluster,front hood n bumper n cover? Thread Starter — sledchickie Forum — Ski-Doo: REV Sleds Replies — 0 Last Post — 01-15-2010 08:10 PM

All times are GMT -6. The time now is 04:24 PM.