For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: IQ 2005-Current, all models in the IQ and IQ Raw chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-15-2018, 08:00 PM
ThSimpson's Avatar
ThSimpson ThSimpson is offline
Currently: Ready for snow.
Join Date: Oct 2012
Location: Holyoke, Colo
Age: 47
Posts: 87
Thanks: 16
Thanked 13 Times in 7 Posts
Rep Power: 547738
ThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond repute
Default Spark, but no run

08 Dragon died on mountian. It has spark, but will not run. I can poor fuel down plugs and it will run for a few seconds then dies. Any ideas?
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-15-2018, 08:03 PM
89sandman's Avatar
89sandman 89sandman is offline
Currently: Meadow Muffin
Join Date: Oct 2004
Location: southern oregon
Posts: 4,801
Thanks: 330
Thanked 1,254 Times in 701 Posts
Rep Power: 21474855
89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute
Default

Fuel pump. Either power or ground to it or the pump itself would be where I'd start.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 03-16-2018, 01:45 PM
sumtinwong sumtinwong is offline
Currently: Not set.
Join Date: Oct 2016
Location: north pole alaska
Basic Member
Age: 39
Posts: 582
Thanks: 170
Thanked 128 Times in 94 Posts
Rep Power: 7871139
sumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond repute
Default

yep no fuel its the pump or a filter/frozen line. #1 DE thaw the sled see if it starts #2 check filters/screens see if it starts #3 if 1 and 2 don't fix it check the wire harness if its good just grab a new pump and go riding before the snow is gone! good luck
Reply With Quote


Rate this post: Yes | No
  #4  
Old 03-16-2018, 05:07 PM
Scott's Avatar
Scott Scott is offline
Currently: ACTIVELY defend your right to ride.
Join Date: Nov 1998
Location: W Mont
Polaris & Montana Moderator
Age: 46
Posts: 68,010
Thanks: 16,665
Thanked 7,934 Times in 4,586 Posts
Rep Power: 21474925
Scott has a reputation beyond reputeScott has a reputation beyond reputeScott has a reputation beyond reputeScott has a reputation beyond reputeScott has a reputation beyond reputeScott has a reputation beyond reputeScott has a reputation beyond reputeScott has a reputation beyond reputeScott has a reputation beyond reputeScott has a reputation beyond reputeScott has a reputation beyond repute
Garage
Default

Three things needed to make fire:

Air
Fuel
Spark

If you have fuel and air, then you have an electric or electronic issue.
__________________
OEM parts from Free Agent

Ambassador for:
FB & IG: Scott Stiegler

Honestly, Honey!!! The shop paid for these mods. They sponsor me now. Really!

Check out these cool products:
Reply With Quote


Rate this post: Yes | No
  #5  
Old 03-16-2018, 05:24 PM
89sandman's Avatar
89sandman 89sandman is offline
Currently: Meadow Muffin
Join Date: Oct 2004
Location: southern oregon
Posts: 4,801
Thanks: 330
Thanked 1,254 Times in 701 Posts
Rep Power: 21474855
89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute89sandman has a reputation beyond repute
Default

In a engine a little compression helps
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to 89sandman For This Useful Post:
Murph (11-13-2018)
  #6  
Old 11-11-2018, 07:00 PM
ThSimpson's Avatar
ThSimpson ThSimpson is offline
Currently: Ready for snow.
Join Date: Oct 2012
Location: Holyoke, Colo
Age: 47
Posts: 87
Thanks: 16
Thanked 13 Times in 7 Posts
Rep Power: 547738
ThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond reputeThSimpson has a reputation beyond repute
Default

Quote:
Originally Posted by ThSimpson View Post
08 Dragon died on mountian. It has spark, but will not run. I can poor fuel down plugs and it will run for a few seconds then dies. Any ideas?

Fuel pump was spraying fuel out the hose. New pump starts runs. No a low voltage issue!
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — What Spark Plugs do you run? Thread Starter — Newby2sleds Forum — Polaris: Pro-Ride Replies — 18 Last Post — 02-22-2014 12:36 PM
Thread — Best spark plugs to run in RMK 700??? Thread Starter — indyseriesnick Forum — Polaris: GEN 2 Replies — 7 Last Post — 12-22-2012 06:03 PM
Thread — Spark Plug - dual spark vs single spark Thread Starter — SledsWest Forum — Fouled Plug Replies — 2 Last Post — 08-19-2012 12:36 AM
Thread — Video on diagnosing no spark, low spark or intermitten spark condition on 1990's Cats Thread Starter — Blaine Forum — Arctic Cat: Powder Special and older Replies — 0 Last Post — 12-29-2009 09:56 PM
Thread — Should I run one heat range cooler spark plug? Thread Starter — JamesS Forum — Performance/Modified Replies — 4 Last Post — 02-06-2009 01:50 AM

All times are GMT -6. The time now is 08:00 AM.

no new posts