For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: TURBO Turbo discussion for Polaris aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-07-2018, 10:26 PM
Octanee Octanee is offline
Currently: Not set.
Join Date: Nov 2010
Location: Cranbrook Bc
Age: 38
Posts: 765
Thanks: 45
Thanked 49 Times in 48 Posts
Rep Power: 2915775
Octanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond repute
Default Exhaust/Power valves

Hey guys, does anybody have any experience with them exhaust valves and when they don't work what happens? I have tried searching and haven't come up with much. does the sled ever cut out/fall on its face after starting a pull? I had that happen a few times. I stumbled across this video, exact sound at 3:56 https://youtu.be/C6U2KPGbmpA?t=3m50s same as the sound my sled made last ride however it still pulled rpm ~8k or so, probably due to the turbo helping it. I also noticed my air fuel fluctuated oddly between 12:1-15 ish really fast while the bog/stutter happened.

I have checked my valves and the diaphragm and the ports, all is clean and no blockages/ issues I can see.

any way to test the solenoid that controls the valves? when the sled is off should the solenoid be closed off or open? Do they stick? I read on the older 900cfi sled some guys were drilling out that small hole under the diaphragm. (although mines not plugged but while im at it?)


Thanks!

Last edited by Octanee; 03-07-2018 at 10:31 PM.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-08-2018, 10:26 AM
AKFULLTHROTTLE's Avatar
AKFULLTHROTTLE AKFULLTHROTTLE is offline
Currently: Waiting for my Polaris 850!
Join Date: Dec 2009
Location: Alaska
Age: 37
Posts: 1,880
Thanks: 617
Thanked 813 Times in 410 Posts
Rep Power: 21474846
AKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond repute
Default

Yes they can cause it but I had more issues on my EGT sensor with the boosted Pro.
__________________
Full Throttle Customs
Alaska Silber Turbos Dealer
http://www.silberturbos.com/
Reply With Quote


Rate this post: Yes | No
  #3  
Old 03-08-2018, 01:20 PM
Octanee Octanee is offline
Currently: Not set.
Join Date: Nov 2010
Location: Cranbrook Bc
Age: 38
Posts: 765
Thanks: 45
Thanked 49 Times in 48 Posts
Rep Power: 2915775
Octanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond repute
Default

Quote:
Originally Posted by AKFULLTHROTTLE View Post
Yes they can cause it but I had more issues on my EGT sensor with the boosted Pro.
What were your symptoms with the egt? I had swapped mine a few weeks ago with my spare sled but you never know....
Reply With Quote


Rate this post: Yes | No
  #4  
Old 03-08-2018, 04:46 PM
tmberro tmberro is offline
Currently: Not set.
Join Date: Sep 2009
Basic Member
Age: 29
Posts: 349
Thanks: 110
Thanked 225 Times in 57 Posts
Rep Power: 12985122
tmberro has a reputation beyond reputetmberro has a reputation beyond reputetmberro has a reputation beyond reputetmberro has a reputation beyond reputetmberro has a reputation beyond reputetmberro has a reputation beyond reputetmberro has a reputation beyond reputetmberro has a reputation beyond reputetmberro has a reputation beyond reputetmberro has a reputation beyond reputetmberro has a reputation beyond repute
Default

I didn't watch the link you posted, but I did just have power valve issues.

2016 Turboed 800 - ~8psi boost.

My sled went from pulling 8450 to ~8000 instantly. Ended up being a broken cable for the power valves.
Reply With Quote


Rate this post: Yes | No
  #5  
Old 03-08-2018, 05:11 PM
AKFULLTHROTTLE's Avatar
AKFULLTHROTTLE AKFULLTHROTTLE is offline
Currently: Waiting for my Polaris 850!
Join Date: Dec 2009
Location: Alaska
Age: 37
Posts: 1,880
Thanks: 617
Thanked 813 Times in 410 Posts
Rep Power: 21474846
AKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond repute
Default

Quote:
Originally Posted by Octanee View Post
What were your symptoms with the egt? I had swapped mine a few weeks ago with my spare sled but you never know....
Well mine would bog off an on. The other issue I always had with the Pro was the reeds which were the same symptoms. Bogs a lot, falling on its face.

Not that you dont have a EV issue but i never had any on my boosted pro.
__________________
Full Throttle Customs
Alaska Silber Turbos Dealer
http://www.silberturbos.com/
Reply With Quote


Rate this post: Yes | No
  #6  
Old 03-08-2018, 06:49 PM
Octanee Octanee is offline
Currently: Not set.
Join Date: Nov 2010
Location: Cranbrook Bc
Age: 38
Posts: 765
Thanks: 45
Thanked 49 Times in 48 Posts
Rep Power: 2915775
Octanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond repute
Default

Quote:
Originally Posted by AKFULLTHROTTLE View Post
Well mine would bog off an on. The other issue I always had with the Pro was the reeds which were the same symptoms. Bogs a lot, falling on its face.

Not that you dont have a EV issue but i never had any on my boosted pro.
Good info. Did your exhaust sensor ever throw a code? I will re-swap my exhaust sensors for the heck of it. Reeds wise I don't have much first hand experience yet. The sled starts great every time, last ride it would Rev up just fine and no backfires nor any bogs per say, it rev'd up and wound out then fell on its face once or twice then after that it did that weird stutter like in the video, I could also boost it in and out of the throttle down the trail and it was ok doing that, wide open was acting up. They are also new and it's been mostly trail miles, sled hasn't wanted to run for me all winter so I haven't had much of a winter lol but that doesn't mean the reeds are still good.
Reply With Quote


Rate this post: Yes | No
  #7  
Old 03-09-2018, 10:05 AM
AKFULLTHROTTLE's Avatar
AKFULLTHROTTLE AKFULLTHROTTLE is offline
Currently: Waiting for my Polaris 850!
Join Date: Dec 2009
Location: Alaska
Age: 37
Posts: 1,880
Thanks: 617
Thanked 813 Times in 410 Posts
Rep Power: 21474846
AKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond repute
Default

I went through reeds about 400-700 miles on the Pro. Mine never through a code but was stored in there only viewable with a digital wrench.

Also make sure you gap your plugs to a .018. To large of a gap will cause the spark to be blow out and cause a pop/cut out.
__________________
Full Throttle Customs
Alaska Silber Turbos Dealer
http://www.silberturbos.com/
Reply With Quote


Rate this post: Yes | No
  #8  
Old 03-09-2018, 11:17 AM
Octanee Octanee is offline
Currently: Not set.
Join Date: Nov 2010
Location: Cranbrook Bc
Age: 38
Posts: 765
Thanks: 45
Thanked 49 Times in 48 Posts
Rep Power: 2915775
Octanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond repute
Default

Quote:
Originally Posted by AKFULLTHROTTLE View Post
I went through reeds about 400-700 miles on the Pro. Mine never through a code but was stored in there only viewable with a digital wrench.

Also make sure you gap your plugs to a .018. To large of a gap will cause the spark to be blow out and cause a pop/cut out.

Good info, I'll swap my exhaust sensor for this weekend, clean the power valves anyways, verify the solenoid is not bleeding air, put new plugs in again, I have them gapped to 20 though, ran great all this time otherwise but you never know. New fuel filter again just because lol, I think ill check my turbo injectors again since it's not a big deal. Going to verify my vacuum lines off the carbs are fine, (boost gauge was reading just fine). And hope between all that, that it will run good.
Reply With Quote


Rate this post: Yes | No
  #9  
Old 03-10-2018, 09:52 PM
Octanee Octanee is offline
Currently: Not set.
Join Date: Nov 2010
Location: Cranbrook Bc
Age: 38
Posts: 765
Thanks: 45
Thanked 49 Times in 48 Posts
Rep Power: 2915775
Octanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond repute
Default

Just did a bench run with the sled, here's what, it's doing now. I got it on video. Did everything I said I would do, no Change. Exhaust valves are clean as can be and move freely.

https://youtu.be/5s1ixXSMRHU
Reply With Quote


Rate this post: Yes | No
  #10  
Old 03-11-2018, 06:45 PM
Octanee Octanee is offline
Currently: Not set.
Join Date: Nov 2010
Location: Cranbrook Bc
Age: 38
Posts: 765
Thanks: 45
Thanked 49 Times in 48 Posts
Rep Power: 2915775
Octanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond repute
  #11  
Old 03-12-2018, 12:06 PM
AKFULLTHROTTLE's Avatar
AKFULLTHROTTLE AKFULLTHROTTLE is offline
Currently: Waiting for my Polaris 850!
Join Date: Dec 2009
Location: Alaska
Age: 37
Posts: 1,880
Thanks: 617
Thanked 813 Times in 410 Posts
Rep Power: 21474846
AKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond reputeAKFULLTHROTTLE has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

  #12  
Old 03-12-2018, 09:47 PM
Octanee Octanee is offline
Currently: Not set.
Join Date: Nov 2010
Location: Cranbrook Bc
Age: 38
Posts: 765
Thanks: 45
Thanked 49 Times in 48 Posts
Rep Power: 2915775
Octanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

  #13  
Old 03-13-2018, 04:11 PM
ez-ryder ez-ryder is online now
Currently: Not set.
Join Date: Nov 2007
Location: Dawson Creek B.C.
Age: 36
Posts: 150
Thanks: 4
Thanked 16 Times in 15 Posts
Rep Power: 990635
ez-ryder has a reputation beyond reputeez-ryder has a reputation beyond reputeez-ryder has a reputation beyond reputeez-ryder has a reputation beyond reputeez-ryder has a reputation beyond reputeez-ryder has a reputation beyond reputeez-ryder has a reputation beyond reputeez-ryder has a reputation beyond reputeez-ryder has a reputation beyond reputeez-ryder has a reputation beyond reputeez-ryder has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

The Following User Says Thank You to ez-ryder For This Useful Post:
Octanee (03-13-2018)
  #14  
Old 03-13-2018, 05:24 PM
Octanee Octanee is offline
Currently: Not set.
Join Date: Nov 2010
Location: Cranbrook Bc
Age: 38
Posts: 765
Thanks: 45
Thanked 49 Times in 48 Posts
Rep Power: 2915775
Octanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond reputeOctanee has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — New Exhaust Valve Gasket kit for power valves PN 3006-329 Arctic Ca Thread Starter — trdehmer Forum — Carb/Airbox/Reeds (Swapmeet) Replies — 0 Last Post — 09-24-2015 12:02 PM
Thread — 2009 Polaris 800 exhaust power valves Thread Starter — Polarisrder Forum — Engine/Engine Parts (Swapmeet) Replies — 1 Last Post — 03-19-2014 12:21 AM
Thread — M8/F8 Bellows Style Exhaust Power Valves Thread Starter — Devilmanak Forum — Engine/Engine Parts (Swapmeet) Replies — 0 Last Post — 11-30-2012 04:25 PM
Thread — Arctic Cat Servomotor & exhaust power valves 800 900 Thread Starter — Boondockin800 Forum — Engine/Engine Parts (Swapmeet) Replies — 1 Last Post — 04-19-2010 09:55 PM
Thread — m1000 Exhaust power valves Thread Starter — Exmnt Forum — Engine/Engine Parts (Swapmeet) Replies — 1 Last Post — 01-20-2009 06:31 PM

All times are GMT -6. The time now is 07:21 AM.

no new posts