For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: TURBO Turbo discussion for Polaris aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 12-26-2018, 11:14 AM
Dzurowsk Dzurowsk is offline
Currently: Not set.
Join Date: Dec 2018
Basic Member
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Dzurowsk is an unknown quantity at this point
Default Silber axys 800 rmk install sidepanel interference

Hello, I am new to the forum and figured I would seek everybody's advice on here. I have just installed a Silber turbo on my 2016 axys 800 rmk and everything went well accept for the fact the turbo actuator contacts the side panel when installed. Does anybody else have this issue and if so has it caused any problems? I have tried to move it over but does not seem possible without any heavy modifications. Thanks
Reply With Quote


Rate this post: Yes | No
  #2  
Old 12-26-2018, 11:59 AM
WAsledder WAsledder is offline
Currently: Not set.
Join Date: Nov 2018
Location: Cle Elum WA
Age: 30
Posts: 138
Thanks: 63
Thanked 27 Times in 22 Posts
Rep Power: 778729
WAsledder has a reputation beyond reputeWAsledder has a reputation beyond reputeWAsledder has a reputation beyond reputeWAsledder has a reputation beyond reputeWAsledder has a reputation beyond reputeWAsledder has a reputation beyond reputeWAsledder has a reputation beyond reputeWAsledder has a reputation beyond reputeWAsledder has a reputation beyond reputeWAsledder has a reputation beyond reputeWAsledder has a reputation beyond repute
Default

My silber is really close to touching the side panel and I noticed when I rolled the sled over or the sled was laying on its side panel it would melt the panel. I ended up heat taping the side panel and haven't had any issues since.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 12-26-2018, 02:03 PM
Boston Racing's Avatar
Boston Racing Boston Racing is offline
Currently: Living the Dream.....
Join Date: Nov 2007
Location: Colorado Springs, CO
Posts: 3,490
Thanks: 459
Thanked 1,102 Times in 584 Posts
Rep Power: 21474851
Boston Racing has a reputation beyond reputeBoston Racing has a reputation beyond reputeBoston Racing has a reputation beyond reputeBoston Racing has a reputation beyond reputeBoston Racing has a reputation beyond reputeBoston Racing has a reputation beyond reputeBoston Racing has a reputation beyond reputeBoston Racing has a reputation beyond reputeBoston Racing has a reputation beyond reputeBoston Racing has a reputation beyond reputeBoston Racing has a reputation beyond repute
Default

There is a nipple on some of the side panels that contacts the blow off valve housing. Grab a pair of diagonal cutters and remove it. Then you will be good to go.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to Boston Racing For This Useful Post:
WAsledder (12-26-2018)
  #4  
Old 03-08-2019, 07:28 AM
braapin braapin is offline
Currently: Not set.
Join Date: Nov 2007
Location: Sandpoint, Idaho
Age: 34
Posts: 513
Thanks: 34
Thanked 36 Times in 19 Posts
Rep Power: 0
braapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond repute
Default

I have interference with my side panel as well after clipping off those tabs. Any ideas ?pictures of where it’s touching...



Sent from my iPhone using Tapatalk
Reply With Quote


Rate this post: Yes | No
  #5  
Old 03-08-2019, 07:49 AM
willjogervais willjogervais is offline
Currently: Not set.
Join Date: Mar 2011
Location: SW Minnesota
Age: 39
Posts: 432
Thanks: 184
Thanked 154 Times in 84 Posts
Rep Power: 15803047
willjogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond repute
Default

I had the same problem on my 16 and now on my 19. Heat tape it and run it. No problems for me
Reply With Quote


Rate this post: Yes | No
  #6  
Old 03-08-2019, 08:01 AM
braapin braapin is offline
Currently: Not set.
Join Date: Nov 2007
Location: Sandpoint, Idaho
Age: 34
Posts: 513
Thanks: 34
Thanked 36 Times in 19 Posts
Rep Power: 0
braapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond reputebraapin has a reputation beyond repute
Default

Looks like it’s actually from damage from previous owner of sled - he hit something and it pooched side panel in a little bit right at those little tits that I clipped off. Guessing that’s the deal. Bought some heavy heat tape. Or maybe I can trim side panel a little? Guessing there’s no moving that valve ?


Sent from my iPhone using Tapatalk
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Avalanche/radio interference axys Thread Starter — Thurel Forum — Polaris: AXYS Replies — 33 Last Post — 03-25-2018 01:53 PM
Thread — Silber turbo install? 2016 Axys Thread Starter — rockin rmk Forum — Polaris: TURBO Replies — 7 Last Post — 02-19-2018 08:12 PM
Thread — Installing silber turbo on 16 axys what should I do/check before install? Thread Starter — Prormk99 Forum — Polaris: TURBO Replies — 7 Last Post — 10-17-2016 12:11 PM
Thread — 16 polaris Axys rmk 800 Silber turbo build Thread Starter — purepolaris600 Forum — Polaris: TURBO Replies — 7 Last Post — 03-27-2016 12:51 PM
Thread — AXYS SILBER TURBO INSTALL...in under 48 minutes Thread Starter — tudizzle Forum — Polaris: TURBO Replies — 14 Last Post — 02-22-2016 08:51 PM

All times are GMT -6. The time now is 06:45 PM.




no new posts