• I've received emails and PM's asking me about "Group Buys" and promotions.

    A Group Buy here on SnoWestOnline.com would be a situation where a normal member (non vendor or mfg) personally collects orders from other members. That member then uses those orders to negotiate a better price with the Vendor/Mfg for HIS/HER "Group" of buyers.

    Here is an example of a viable "Group Buy"

    http://www.snowestonline.com/forum/showthread.php?t=269222

    A promotion that has the words "Group Buy" in the title is still a promotion, and from the rules that were handed down to me by Harris Publications is that non-advertisers cannot run promotions or open sales programs on the forums outside of the swapmeet.

    If a members wants to become a group buy manager, maintain a thread and collect the funds and negotiate a group buy... as a member, you are welcome to do that as long as you are not attached to the business of the vendor or Mfg.

    If you are a vendor/MFG and you want to offer an EXCLUSIVE "SnoWestOnline ONLY" promotion that is exclusive to snowest readers, please contact me and you'll be able to put it up in the Polaris forums.

    Also, before any vendors/mfgs get all "riled up" over this know that the moderators are strictly volunteers and do not receive a dime from any advertising $$ spent on this site.

    As ALWAYS, since DAY ONE of me becoming a moderator, I have pioneered, supported and encouraged vendors and mfgs in getting the word out to our readers with "New Product Announcements.

    Have a great season.

    From this point on, all vendors/mfg's promoting Pre-Season tiered sales programs, in the Polaris Forums, that are not paid advertisers will be appropriately moved to the swapmeet section of the forums.

    MH

Sled has Random Bog

WyoUltra

Well-known member
Lifetime Membership
Nov 26, 2007
566
58
28
Casper, WY
Had my sled out this weekend, trying to get the twins dialed in on it. Engine is out of a 2005 700 RMK. The previous owner told me the pipes are supposed to be made for this sled/motor by SLP. I'm running 360/370 mains, +10k ft, and my needle clips are in the top slots. Sled runs great for about 15 minutes or so, then it sounds like it drops a cylinder. It will do this for maybe 5 minutes then clear up, this is a repetitive cycle. It's almost like it only does this when the pipe are at temp, when they're cold it doesn't have a problem. I do know it's firing on both plug wires when running rough. Plugs look a tad on the rich side, good in my opinion.

I did call SLP and get their recommended jetting for this sled, They claimed they never made IQR SLP pipes for a 700 edge engine. However I'm running the tuning based off of the 2002 700 twin pipes for the edge RMK chassis. I wonder if these pipes are for a different motor, I do know that they are made (stamped) by SLP.

Will follow up with a few clips of it running and some plug pictures.
 
Last edited:

High Voltage

Well-known member
Lifetime Membership
Jan 30, 2003
1,511
1,155
113
Helena, MT
Plug one looks like it is not running well. I would drop a different plug in that hole for starters.
 

WyoUltra

Well-known member
Lifetime Membership
Nov 26, 2007
566
58
28
Casper, WY
Plug one looks like it is not running well. I would drop a different plug in that hole for starters.
I did change plugs in it on sunday afternoon, the plugs above are BR8IEX (NGK iridiums). I swapped out to a BR9ES, one was brand new the other was used but clean. The issue with that is only one of them was readable because the used one was pretty black from the last time it was ran. I ran the BR9 for 5 minutes in a field, then the rest of the clip above, back to the truck. The ride back to the truck was mostly wide open except the few times I chopped the throttle.

I don't think it's a jetting issue. I think I'm having a coil problem or something else electrical related. In the past when I have had bad coils though, they were just bad, it wasn't like there was good and bad moments.
 

High Voltage

Well-known member
Lifetime Membership
Jan 30, 2003
1,511
1,155
113
Helena, MT
I had a stator go bad, but tested ok with ohm meter on the sled. The more load I put on it the worst it ran. Load was hand warmers on high and headlights on bright.
 
Premium Features