Seized 2008 PTEK help!

Jan 9, 2020
2
0
1
So I cant really find anything specific about what I am wondering so I decided to create an account and post a discussion since I am always looking around in these forums anyways lol!!


So, I recently seized the engine in my 2008 Summit 800R PTEK, I will sum up the last ride for you guys: Warmed up the sled, went riding and it was running fine (but sounded kind of starved? Or lean???) And also felt like it wouldn't downshift right away after letting off from a WOT pull which I personally thought may have been from improper belt deflection (I just attempted to tighten my belt, it was loose) so I didnt pay TOO much mind to it. Kept ripping, and maybe 10-15 after I initially took off it happened... I came around a turn at slow speed, and I was cruising for a little probably around 30kmh when I started gradually applying throttle and once I got to full throttle for maybe 2-3 seconds it completely died without warning, I heard one quick bang (not loud, actually kind of quiet compared to the sound of the engine before it went silent) and then came to a rolling stop.

Now I am no where near a mechanic (am actually new to this sport) and have a few questions/theories as to what could have caused this to happen

1. My primary clutch would knock around engagement RPM, but this has been going on since I got the sled a few weeks ago and I heard of others with the same noises but no issues so idk.

2. (This is what I feel like may have caused it): When I first got the sled, it ran really funny and had no power. After changing the plugs and throwing in premix it ran nice, so we figured it was a broken oiler (there was also some weird thick purple substance is the oil reservoir, it was not empty) and I was on my way. Now, after looking at it (I haven't taken it apart yet) I noticed that all of the liquid that was in the reservoir was gone, it was completely dry!!! So I think that the oiler was not broken, and once it ran out of oil (or whatever was in there lol) even though I was running premix, there was no longer oil being pumped to the water pump shaft or whatever (something I just learned today, thanks internet) and that caused the engine to obviously malfunction.

Like I said, I dont know much if anything at all so I want thoughts and opinions from you sled-wizards! Thanks in advance!!!!
 
Jan 9, 2020
2
0
1
Wondering if I should just part it out at this point aswell honestly. I only got to ride like 5 times and I dont want to wrench the rest of my first season away but the way it looks I might not be riding for the rest of it either way. reinvest part-out $$ and look forward to next year?
 
Premium Features