• I've received emails and PM's asking me about "Group Buys" and promotions.

    A Group Buy here on SnoWestOnline.com would be a situation where a normal member (non vendor or mfg) personally collects orders from other members. That member then uses those orders to negotiate a better price with the Vendor/Mfg for HIS/HER "Group" of buyers.

    Here is an example of a viable "Group Buy"

    http://www.snowestonline.com/forum/showthread.php?t=269222

    A promotion that has the words "Group Buy" in the title is still a promotion, and from the rules that were handed down to me by Harris Publications is that non-advertisers cannot run promotions or open sales programs on the forums outside of the swapmeet.

    If a members wants to become a group buy manager, maintain a thread and collect the funds and negotiate a group buy... as a member, you are welcome to do that as long as you are not attached to the business of the vendor or Mfg.

    If you are a vendor/MFG and you want to offer an EXCLUSIVE "SnoWestOnline ONLY" promotion that is exclusive to snowest readers, please contact me and you'll be able to put it up in the Polaris forums.

    Also, before any vendors/mfgs get all "riled up" over this know that the moderators are strictly volunteers and do not receive a dime from any advertising $$ spent on this site.

    As ALWAYS, since DAY ONE of me becoming a moderator, I have pioneered, supported and encouraged vendors and mfgs in getting the word out to our readers with "New Product Announcements.

    Have a great season.

    From this point on, all vendors/mfg's promoting Pre-Season tiered sales programs, in the Polaris Forums, that are not paid advertisers will be appropriately moved to the swapmeet section of the forums.

    MH

Run Away After Rebuild!?!?!?

Dec 7, 2012
91
4
8
Hey all, finally got the ole 2013 Pro 800 back together today after a full engine rebuild. I wired the oil pump open and went to start it up. It immediately revved like it was full throttle..... WTF? I took the wire off the oil pump and tried again with the same result.
I checked throttle free play, and opened/closed the throttle and can hear the throttle bodies clicking shut. I never touched the TPS adjustment and all the wires are plugged in.
Has anyone else run into this before? Any ideas as to how this is even possible?
TIA.
 

tuneman

Well-known member
Lifetime Membership
Jan 16, 2013
940
852
93
Minnesota
www.everettsports.net
A runaway on a 2-stroke is a lean condition. So either an air leak or lack of fuel. Did you do a leak down test on the engine after you put it together? The fact that it runs normal now usually points to a lack of fuel. That's easily explained with a carbed engine, but odd for a fuel injected one.
 
Premium Features