Rough idling 2020experts

801_FuNk_801

Active member
Lifetime Membership
Premium Member
Feb 6, 2008
220
35
28
Ogden, Ut
So are the plugs just not torqued correctly from the factory? or are they not putting a plug that can index in?
 

PaulAnd

Well-known member
Premium Member
Oct 17, 2010
2,040
440
83
Northern IL.
I ordered and installed plugs from napa
And they almost didn’t make it to the correct index zone
I think I read somewhere on the interwebs that somebody else couldn’t get napa supplied plugs to index perfectly.
No way to torque the plugs without taking airbox out


Plugs have 1200 miles



Sent from my iPhone using Tapatalk
 

Reg2view

Well-known member
Lifetime Membership
Feb 1, 2010
1,986
1,095
113
Worst case, get a simple spark plug index washer set - you'll find it easy to index and set torque. With that said, this is another BS assembly issue; unfortunately, I wouldn't want the peeps actually doing PDI at a dealer touching it, either.
 

sledhead_24_7

Well-known member
Lifetime Membership
Premium Member
Jul 30, 2008
2,308
732
113
Jackson Wy
On previous Etecs. Skidoo paid NKG extra to make sure all the plugs were indexed properly for their engines. That may not be occurring anymore, or someone was not doing their job.

As a result if a person went to their local auto parts store and bought a set of plugs, those would not have been properly indexed for the skidoo motors. Vs the ones sold at the dealer, provided the dealer bought the plugs direct from skidoo.
 

Blu Du

Well-known member
Premium Member
Feb 19, 2008
4,681
1,564
113
45
Nisswa Mn.
dealer said they checked my plugs and it still idled like ****. my shot was randomly working on and off and for some reason they say that they are both related to crank angle sensor. they are waiting to hear back from brp
 
Last edited:
Premium Features