• I've received emails and PM's asking me about "Group Buys" and promotions.

    A Group Buy here on SnoWestOnline.com would be a situation where a normal member (non vendor or mfg) personally collects orders from other members. That member then uses those orders to negotiate a better price with the Vendor/Mfg for HIS/HER "Group" of buyers.

    Here is an example of a viable "Group Buy"

    http://www.snowestonline.com/forum/showthread.php?t=269222

    A promotion that has the words "Group Buy" in the title is still a promotion, and from the rules that were handed down to me by Harris Publications is that non-advertisers cannot run promotions or open sales programs on the forums outside of the swapmeet.

    If a members wants to become a group buy manager, maintain a thread and collect the funds and negotiate a group buy... as a member, you are welcome to do that as long as you are not attached to the business of the vendor or Mfg.

    If you are a vendor/MFG and you want to offer an EXCLUSIVE "SnoWestOnline ONLY" promotion that is exclusive to snowest readers, please contact me and you'll be able to put it up in the Polaris forums.

    Also, before any vendors/mfgs get all "riled up" over this know that the moderators are strictly volunteers and do not receive a dime from any advertising $$ spent on this site.

    As ALWAYS, since DAY ONE of me becoming a moderator, I have pioneered, supported and encouraged vendors and mfgs in getting the word out to our readers with "New Product Announcements.

    Have a great season.

    From this point on, all vendors/mfg's promoting Pre-Season tiered sales programs, in the Polaris Forums, that are not paid advertisers will be appropriately moved to the swapmeet section of the forums.

    MH

Project 2001 RMK 700 Rebuild.

Oct 20, 2014
105
7
18
So I bought a barely running sled that sounded pretty bad, but it did start and run and move under its own power. 90PSI PTO side, 130 NON PTO Side.

Got it home tonight, drained some of the coolant so I could take the heads off and look at the top of the pistons and see what damage was done.

Luckily the heads look fine, the jugs actually don't look too bad... I am hoping I can just hone them and throw in new pistons. Wont know until tomorrow when I remove the jugs completely.

Here is a short clip of the side of the pistons... Looking in the exhaust ports.

https://www.youtube.com/watch?v=YEHJmDDKMk8

Here are some pictures with the heads removed...

IMG_0972.jpg


IMG_0973.jpg


I can already tell it was run really lean as there is zero piston wash... Interested to look at the bottom of the piston crown and see what that tells me. First thing I will be doing is going up two jet sizes.

Any tips to get the front two bolts removed from the jugs? Can't get a socket in there, my wrenches hit the case... Im thinking of buying a cheap 9/16" wrench and grinding it down so there isnt much metal left so I can unbolt that nut... But there has to be something I am missing... I would assume those have torque specs.
 
Last edited:

ryanlinger

Well-known member
Lifetime Membership
Dec 27, 2013
289
57
28
34
Yakima, WA
I was able to just use wrenches. As far as torque make sure you follow the torque specs as best as you can or you will end up pitying new base gaskets in like I did. You can't really torque with the regular wrench so I just did the best I could and everything was fine
 
Oct 20, 2014
105
7
18
Got everything apart and had my mechanic buddy look at it. He said the jugs are salvageable, but one of the jugs may beyond the point of honing... So maybe a .20 over kit may be in my future. I could feel the grooves with my finger nail. Ran way too lean for sure. The top ring on the PTO side was seized.

I am going to take my jugs to a local machine shop and get them done right. The bottom end seems to be ok (whew).

Going to go with a SPI kit.

Both pistons had some seize marks, but overall they weren't horrible. Could have been MUCH worse.

Here is a picture of the piston at 90PSI. Most the damage was on the exhaust port on both pistons... This one being really bad, and the other just some light scratches.

bad_piston.jpg
 
Last edited:

ryanlinger

Well-known member
Lifetime Membership
Dec 27, 2013
289
57
28
34
Yakima, WA
That stuck ring was probably the cause is the low compression I'm sure. Glad to hear your fixing it right. The scratches on the exhaust port side are pretty typical of any mirror I've ever taken apart. Sometimes they are just worse than others.
 

Vern

Well-known member
Lifetime Membership
Jun 14, 2004
2,120
767
113
hyrum utah
May be able to get the jugs renikasiled(sp?), will probably need renik'd if bored out at all also. I don't know how you would check it with the engine apart, but might want to check out the pto crank seal. On a 99 I had I lost the pto side piston and everything else appeared good so I slapped a new piston and jug on it and a short time later it ate the piston again. I did some investigating and found I had a blown crank seal so split the case and the bearings on the pto side of the crank were also toast so had to have the crank rebuilt also. Not tryin to scare you, it may just be a piston. just sayin do as much investigating as you can while its apart to prevent possible future problems.
 
Oct 20, 2014
105
7
18
The motor is still in the sled... Never removed an engine from a sled before... How difficult is it to remove the actual motor? Do I need to remove the chain case gears, the clutch etc? I agree, it could very well be a crank seal or bearing, but no oil was in the tub, like something was leaking...

If its not hard to remove the motor I will give that a shot.
 

Vern

Well-known member
Lifetime Membership
Jun 14, 2004
2,120
767
113
hyrum utah
There's usually little to no leaking with a bad crank seal but they can suck in air through the seal causing a lean condition. Pulling the motor is not gonna show you much as far as a bad crank seal, you might could pull the clutch and look at the seal and see if there's any sign of slight seepage or what not coming out around the crank. That being said that particular sled is pretty easy to get the motor out. The motor will be bolted to either an aluminum plate or two straps that then bolt to the chassis with two bolts in front of and two in back of the engine. Remove those bolts, the belt, exhaust, carbs and the wiring connected to the mag side and it comes right out. The belt is the only connection between the engine and the rest of the drive train so no need to mess with any of that.
 
Oct 20, 2014
105
7
18
Thanks. I will try and get the motor out tonight and split the case...

I looked at my cylinders closer today and they have been ported and polished. The intake runners have been knife edged and polished and the exhaust ports have been ported and polished... He was running twin pipes as well.. No wonder the thing was ran so lean.

Since they have been ported and polished the machine shop wont do anything. They say there is no such thing as a .20 over pistons for this motor and they can only hone one cylinder because the other one is past.

So basically they want $250 to send out one cylinder to get re-nicked to the stock piston diameter again and hone out the other cylinder... Sounds like high way robbery to me... I guess they use diamond hones too, which will eat that nickel like no ones business.

So anyone have any suggestions of a place I can send my cylinders to that does good work and doesn't charge an arm and a leg? I can hone the one cylinder, its not rocket science with a flex hone.

I emailed hiperf.com Because their site shows they sell a .020 over kit...

http://www.hiperf.com/acatalog/700cc.html

So confused.
 
Last edited:

sno*jet

Well-known member
Premium Member
Dec 13, 2007
2,272
784
113
the motors come out very easy. 4 9/16 nuts with washers and then all the coolant/oil lines. i found metric sizes fit the motor better, standard for the chassis stuff. 6 pt. 14mm socket for the jugs. It might not had lean jetting, that looks normal for an old mtn. sled imo thats seen lots of use. people dont warm them up properly, and also overheat them. you should see the one i have. it runs fine but i pulled the motor after finding the water pump bearings were shot, and then saw my pistons a little worse off then yours. mines back in the sled now and going down the road...
Also check your clutch faces for hairline cracks, from the center out. another common problem. hope it helps...
 
Oct 20, 2014
105
7
18
Well, nothing is getting done tonight. The clutch requires a gear puller and I don't have one... The gear pullers I have, the rods are big enough. I am really half tempted to just leave the bottom end alone...

Plus I received my computers new video card, so I will be busy with that tonight.
 

mike_s

Well-known member
Jan 19, 2012
468
254
63
Ashton, Idaho
Well, nothing is getting done tonight. The clutch requires a gear puller and I don't have one... The gear pullers I have, the rods are big enough. I am really half tempted to just leave the bottom end alone...

Plus I received my computers new video card, so I will be busy with that tonight.

DO NOT under any circumstances use a gear puller to remove your clutch! It WILL break the sheaves or top cover! You need to get a specific puller to remove the clutch, available from a number of snowmobile parts vendors or polaris. At the very least take the bottom end into a snowmobile shop and have them pop it off, will only take them 5 minutes and save you a few hundred on a new clutch.

Edit: this is what you need : https://www.denniskirk.com/cmp/pro-snow-clutch-puller-polaris.p28906.prd/28906.sku
 
Last edited:
Oct 20, 2014
105
7
18
I guess I am confused... You don't need to remove your clutch in order to remove the engine? I would assume its harder to remove it once its already out of the sled... I found a 3/4-16" bolt and that's the same pitch/thread as a gear puller.

1. Add water into clutch hole
2. wrap teflon tape around bolt threads.
3. screw in bolt and clutch pops off.

Much cheaper than a $30 tool.

I figured I would leave the water pump and oil pump on, remove the engine with those two components as they are easy to remove later.

Just got off the phone with Hi Performance and they were helpful. They said that the SLP Part number is 09-722-02 for .020 over pistons, they just started carrying these pistons as they are fairly new... The nice lady on the phone said they came available in late 2012, early 2013. So this is more than likely why my local shop had no idea they were available.

She said they have sold 7 pistons since 2013, so obviously people are using them...

So if anyone here has some old cylinders that are worn too far past, depending on the price... You can use them still if you get them bored .020 over. Here it costs $85 a cylinder to get them bored... That's spendy considering you need to re-nick them at $250 a pop. Cheaper to buy stock remand cylinders off eBay.
 
Last edited:

mike_s

Well-known member
Jan 19, 2012
468
254
63
Ashton, Idaho
To avoid confusion:

Gear puller top pic, clutch puller bottom pic.

Don't use the tool in the top pic.

Sent From God Knows Where...
 

Attachments

  • uploadfromtaptalk1415809968256.jpg
    uploadfromtaptalk1415809968256.jpg
    6.6 KB · Views: 456
  • uploadfromtaptalk1415810057576.jpg
    uploadfromtaptalk1415810057576.jpg
    7.9 KB · Views: 180
Oct 20, 2014
105
7
18
Ok, so got a little more time to check the sled out... Some more good news.

The sled has Pro Series Fox Shocks all around! I called a local guy who rebuilds them and he said they sound good still. He said they are the newer aluminum style with the bump stops and should be good for a while longer. My sled is on the lowest torsion setting causing the sled to squat really bad, going to adjust that so its on the stiffest setting since I weigh 200 lbs.

Managed to paint my SLP twin pipes with high temp flat black paint along with the exhaust header flange.
Got all my gaskets scraped of all parts.
Ordered new top end gasket set.
Cleaned up my heads using parts cleaner and they are waiting to go in.

I haven't tested my oil pump, any easy way to go about that or make sure its setup correctly? I am thinking I should remove the recoil cover and check my water pump belt...

What primary clutch spring should I use with this sled? It currently has a white spring.

I still need to find a nose bracket, or front bumper bracket or pound my current one into submission so I can close the hood properly... It's the bracket that your hood hinges attach to. That thing is bent badly. Anyone with a part number?
 

sno*jet

Well-known member
Premium Member
Dec 13, 2007
2,272
784
113
belts a good sign. pull it off there and see how those water pump bearings feel!
careful as you re-assemble, that water pump shaft to oil pump connection is known to fail if its not centered perfect. mine had very loose tolerances anyway.
 
Oct 20, 2014
105
7
18
Yea, I have been working 12-16 hour days, haven't had the spare time to remove the engine. The PTO side engine mount up front needs replacing anyhow. Going to try and remove the carbs tomorrow, the hoses and cables and hopefully get the motor out before the weekend. I figure I might as well check the seals out and the bearings since I am this far in. Not much left.
 
Premium Features