Problem with BCA link radio

GreenState

Well-known member
Lifetime Membership
Feb 28, 2012
415
225
43
McCall
Could it be the PIDD gauge that is setting off the interference? I just bought a 17 snocheck with this gauge. I also have the bca radio. Im going up tues the 29. Ill test my radio also.
On my '16 with the basic gauge I had bad interference. As soon as the sled went above idle, the radio squawked. Constantly. I ended up shutting it off unless I needed to talk to someone. Just my BCA though, my Rino never has had an issue.
 

PaulAnd

Well-known member
Premium Member
Oct 17, 2010
1,983
369
83
Northern IL.
All the Poo's in my group make my bca radio freak out
perfectly quiet when they are not around
My cheap midlands radios had no problem with the Poo's
So I'm going to blame Poo and BCA
 

Visi

Well-known member
Lifetime Membership
Nov 26, 2007
816
139
43
31
Paradise, CA
Have an axys, have used my bca radio 30+ times and nothing until my last ride. I don't know why.
 

Eagle5150

New member
Premium Member
Feb 8, 2010
7
3
3
Just rode in Togwotee with BCA Links. Our guide, had us switch to Channel 6, Privacy 7. He said the Axys make the radios squeal on other channels. Rode three days, no problems...
 

hughesfoundation

Well-known member
Oct 7, 2008
421
97
28
Ferndale,Wa.
Just found this thread, I have a 2016 AC proclimb and my BCA radio does the same thing. I thought I had a stator going so tore it apart and all looked good. Guess I need to call BCA.
 

blastco2

Well-known member
Lifetime Membership
Dec 27, 2012
283
80
28
se idaho
A couple of things that might help.... Check the ground straps that should be from engine to chasis. If there is none, install one. Make sure the ignition coil, ecm and gauges are well grounded.
And the simplest, try setting a subaudible tone (sub channel) on your radio. Everyone in your group will have to do the same or you won't hear them. Try different channels and different tones.
Read the wiki article titled CTCSS, to gain an understanding of subaudible tones and what to expect.

Sent from my VS990 using Tapatalk
 
Last edited: