Polaris 120 not getting fuel

Dec 31, 2018
6
3
3
hey guys looking for some help i am no stumped when if comes to my oldest daughters sled... we put it away runnning on the weekend and now we cant get it to run... we have done the following....

cleaned the carb 3 times
made sure valves were properly adjusted .005
ran a seperate fuel line from a jerry can to the carb
chaged the oil in the crank case
checked compression (150psi)

i also took the carb off my youngest daughters sled which is running fine and tried it and still no fuel to the spark plug. the only time we we have been able to get it to idle was when completely blocking off the carb with a piece of carboard over it. it would just idle and wanna backfire and bog when giving it throttle....

any help would be greatly appreciated as i dont know what else to look for.
 
Jan 16, 2018
4
3
3
32
Had some strange fault finding with my son's 120 last week, was pretty sure that I had problems with not getting fuel or something with the valves etc. Spark plug was dry and did give sparks. Turned out to be the spark plug that was bad, ran great after changing it
 
Premium Features