Lean conditions on M8 2011 Push HP PG.. Need advices

w2bridin

Well-known member
Jan 26, 2008
486
96
28
nd
?

I have no idea what your problem is but I can tell you my setup as it is close to yours and it runs awesome. 2010 m8 with push tial PG turbo, race pump, stock ho head, and a 2 deg timming key. I have ran mine at 1000ft elev. 3-400 miles on 100LL at 7.5-8lbs of boost. I have not triped the octane codes yet and it runs great. It runs 12.5 AFR with boost fuel WO. I think your fuel controller is where I would start looking for a problem. good luck
 

JasonAK

Well-known member
Dec 5, 2007
759
134
43
I have no idea what your problem is but I can tell you my setup as it is close to yours and it runs awesome. 2010 m8 with push tial PG turbo, race pump, stock ho head, and a 2 deg timming key. I have ran mine at 1000ft elev. 3-400 miles on 100LL at 7.5-8lbs of boost. I have not triped the octane codes yet and it runs great. It runs 12.5 AFR with boost fuel WO. I think your fuel controller is where I would start looking for a problem. good luck
Where do you get the "Race Pump"?
 

mmsports

Well-known member
Nov 27, 2007
3,118
1,611
113
Preston, Idaho
fuel pressure reg.

We have found some issues with the bdx regs losing pressure in stead of gaining I am replacing all of mine. I am trying to find replacements for them.
 

M Turbo

New member
Dec 11, 2007
41
2
8
Not only the programing is out i think the turbos to small can't keep any of our's temps down. A little programing and bigger turbo this would be a nice kit.
 

mynewuseddoo

Well-known member
May 28, 2009
1,257
641
113
Shuswap
Did you hook up the boost hose to the Attitude box? If it is not hooked up then your Attitude box can't sense how much boost the sled is building and cannot add boost fuel accordingly. Check this hose!