• I've received emails and PM's asking me about "Group Buys" and promotions.

    A Group Buy here on SnoWestOnline.com would be a situation where a normal member (non vendor or mfg) personally collects orders from other members. That member then uses those orders to negotiate a better price with the Vendor/Mfg for HIS/HER "Group" of buyers.

    Here is an example of a viable "Group Buy"

    http://www.snowestonline.com/forum/showthread.php?t=269222

    A promotion that has the words "Group Buy" in the title is still a promotion, and from the rules that were handed down to me by Harris Publications is that non-advertisers cannot run promotions or open sales programs on the forums outside of the swapmeet.

    If a members wants to become a group buy manager, maintain a thread and collect the funds and negotiate a group buy... as a member, you are welcome to do that as long as you are not attached to the business of the vendor or Mfg.

    If you are a vendor/MFG and you want to offer an EXCLUSIVE "SnoWestOnline ONLY" promotion that is exclusive to snowest readers, please contact me and you'll be able to put it up in the Polaris forums.

    Also, before any vendors/mfgs get all "riled up" over this know that the moderators are strictly volunteers and do not receive a dime from any advertising $$ spent on this site.

    As ALWAYS, since DAY ONE of me becoming a moderator, I have pioneered, supported and encouraged vendors and mfgs in getting the word out to our readers with "New Product Announcements.

    Have a great season.

    From this point on, all vendors/mfg's promoting Pre-Season tiered sales programs, in the Polaris Forums, that are not paid advertisers will be appropriately moved to the swapmeet section of the forums.

    MH

help please Rmk 600 runs won't move

Feb 24, 2015
4
1
3
I was riding across the lake to meet a friend I stopped to check the time on my phone didn't shut the sled off went to go again and it would not move it's a 2001 rmk 600 the track will not spin even when I lift it off the ground I can't turn the secondary by hand is my clutch shot or something in the chaincase where should I start thank you for any help
 

sledhed

Well-known member
Premium Member
Dec 19, 2001
1,651
400
83
Lolo, Montana
Melted your HYFAX to the track. Been there, done that on my 99 700 RMK even with idlers. Tip sled up on side, if track won't separate from rails then you will have to break it loose... then run scratchers and kick snow under there once in a while.
 
Feb 24, 2015
4
1
3
Yeah it bogs a little when the primary engages. I will start with checking hyfax hope that's it then I'll open the chain case if the hyfax is not the problem thank you for all the help I'll post up when I get I moving again
 
Feb 24, 2015
4
1
3
So I got the track unstuck from the hyfax it's moving but can only get about 4500 rpm out of it and it's making a loud clicking noise any ideas what could be wrong?
 

Laundryboy

Well-known member
Lifetime Membership
Oct 31, 2012
1,247
312
83
Pinpointing where the clicking is coming from would really help with figuring out the problem.
 

retiredpop

Well-known member
Lifetime Membership
Jul 3, 2001
1,241
267
83
Calgary
You probably "hour glassed" the drive belt when the sliders were stuck. That will make a lot of noise as the drive clutch rotates past the damaged area. Put a new belt on it and retest for noise. Does the track rotate by hand fairly easily?
 

sledhed

Well-known member
Premium Member
Dec 19, 2001
1,651
400
83
Lolo, Montana
The clicking sound might be hyfax material stuck to the track clips. I had to spend some time chipping all that off when it happened to me. Don't know about the 4500 rpm issue, sounds like it is just past engagement, I would suspect belt / clutch issues (replace with known good belt first, and put it on track stand and rev and rotate track and figure out where the click is coming from)...

But get that plastic off of the track clips, and might have to replace hyfax or hyfax might have chunks broken out from freeing the track from it which would make a clicking noise when clips go over them. Trackstand and pinpoint noise and let us know...
 
Feb 24, 2015
4
1
3
I looked over the hyfax no chunks missing clips looked clean put a new belt on and back to rippin no more clicking sound thank you everyone for all your help I really appreciate all the info
 
Premium Features