Head dribble...🤔

summ8rmk

Too handsome
Lifetime Membership
Premium Member
Feb 16, 2008
11,160
4,584
113
yakima, wa.
My 19 Alpha has a leaky head...
I replaced the O-rings and torqued to 25lbs.
Still leaking.
Any thoughts?
Anyone else have this issue?

I don't have to add coolant every ride as it looses less than 1 oz.

I pressurized the system at 13psi and it held solid for 10 min but still seeped.

19psi for 1 hr and it dropped to 18.5psi.

Not sure if it's the head or jugs that are not perfectly flat?
It leaks from the same place after new o-rings. The back near the water pump hose.


Sent it
 
Last edited:

MTN_VIPER

Well-known member
Lifetime Membership
Nov 26, 2007
889
372
63
NW WA St.
fourstrokesolutionsllc.com
My 18 was leaking at the water pump seal and had drips hanging from the hose back there. It was a real slow leak that would leave just a small puddle a couple of inches in diameter on the shop floor.
The sled is still under warranty so I had the dealer fix it. He did say that if you replace the w/p seal be sure to replace the impeller also. Otherwise it could still leak and since the motor has to come out fix it, it's not something that you want to do twice.
 
Last edited:

Elkaholic4life

Twin Peaks
Staff member
Lifetime Membership
Premium Member
Dec 19, 2013
7,326
4,951
113
51
Portland, OR
I recommend pulling the skid and putting it under an axys. Then I'd put a Doo oil cap on the axys, better throw a Yamaha sticker on so no one gets butt hurt 🤣

You know I'm just playing bud. I hope its an easy fix. kinda weird though, don't hear of many cats with motor problems
 
Premium Features