Factory turbo clutch prob question

Oct 13, 2021
10
4
3
Idaho
Picked up new factor turbo at dealer today. In discussion with him he said that after 500 miles they are seeing clutch alignment problems and needing to be aligned. Anybody else have this issue? Curious to know if it’s a big problem as they say! Tia
A moment ago
 

justinkredible56

Well-known member
Lifetime Membership
Dec 24, 2007
1,040
354
83
Eagle Mountain, UT
Picked up new factor turbo at dealer today. In discussion with him he said that after 500 miles they are seeing clutch alignment problems and needing to be aligned. Anybody else have this issue? Curious to know if it’s a big problem as they say! Tia
A moment ago
Ya that kinda correlated with what I saw with mine. I could “feel” the belt starting to slip my second season (first full season) on it.

I aligned my clutches last year with the grip n rip setup and it’s made all the difference, highly recommend!
 
Oct 13, 2021
10
4
3
Idaho
Ya that kinda correlated with what I saw with mine. I could “feel” the belt starting to slip my second season (first full season) on it.

I aligned my clutches last year with the grip n rip setup and it’s made all the difference, highly recommend!
Ya that kinda correlated with what I saw with mine. I could “feel” the belt starting to slip my second season (first full season) on it.

I aligned my clutches last year with the grip n rip setup and it’s made all the difference, highly recommend!
A lot of people were doing clutch kits and wasn’t planning on it but might have to. Thanks
 
Jul 5, 2001
274
163
43
Picked up new factor turbo at dealer today. In discussion with him he said that after 500 miles they are seeing clutch alignment problems and needing to be aligned. Anybody else have this issue? Curious to know if it’s a big problem as they say! Tia
A moment ago
Do your self a favor and put the grip n rip and align when its new, nice and clean and fixes the "out of alignment under load" problem. Guys in our group don't even ride them prior to setting them up..... I have aligned well over a dozen of them and all are out from the factory, from 2018's to 2022's Can you go ride it as it is....sure, but the minute the snow gets heavy and turns to mashed taters it will show its self... just watch the belt temp on the dash.....just my .02
 
Oct 13, 2021
10
4
3
Idaho
Do your self a favor and put the grip n rip and align when its new, nice and clean and fixes the "out of alignment under load" problem. Guys in our group don't even ride them prior to setting them up..... I have aligned well over a dozen of them and all are out from the factory, from 2018's to 2022's Can you go ride it as it is....sure, but the minute the snow gets heavy and turns to mashed taters it will show its self... just watch the belt temp on the dash.....just my .02
Ya it seems that the out of alignment while under load is a common problem. I think I will!
 

wideopenbeau

Well-known member
Lifetime Membership
Dec 19, 2009
79
76
18
Milky Way.
Yep get it aligned right out of the box, I have 3 shim kits and stoppers waiting to go in as soon as the sleds come in……. We have done about 10 sleds and all of them have been out. Once done they don’t seem to move much. We haven’t blown a belt in a long while ether.
 
Premium Features