• .
  • I've received emails and PM's asking me about "Group Buys" and promotions.

    A Group Buy here on SnoWestOnline.com would be a situation where a normal member (non vendor or mfg) personally collects orders from other members. That member then uses those orders to negotiate a better price with the Vendor/Mfg for HIS/HER "Group" of buyers.

    Here is an example of a viable "Group Buy"

    http://www.snowestonline.com/forum/showthread.php?t=269222

    A promotion that has the words "Group Buy" in the title is still a promotion, and from the rules that were handed down to me by Harris Publications is that non-advertisers cannot run promotions or open sales programs on the forums outside of the swapmeet.

    If a members wants to become a group buy manager, maintain a thread and collect the funds and negotiate a group buy... as a member, you are welcome to do that as long as you are not attached to the business of the vendor or Mfg.

    If you are a vendor/MFG and you want to offer an EXCLUSIVE "SnoWestOnline ONLY" promotion that is exclusive to snowest readers, please contact me and you'll be able to put it up in the Polaris forums.

    Also, before any vendors/mfgs get all "riled up" over this know that the moderators are strictly volunteers and do not receive a dime from any advertising $$ spent on this site.

    As ALWAYS, since DAY ONE of me becoming a moderator, I have pioneered, supported and encouraged vendors and mfgs in getting the word out to our readers with "New Product Announcements.

    Have a great season.

    From this point on, all vendors/mfg's promoting Pre-Season tiered sales programs, in the Polaris Forums, that are not paid advertisers will be appropriately moved to the swapmeet section of the forums.

    MH

Axys 800 boondocker turbo

Feb 2, 2019
4
2
3
Hi from Russia :), I use boondocker turbo kit for Axys 2016 with control box , intercooler/ additional fuel lines, Tial exhaust on 2018 Axys 800 , all were normal , but today sled works wrong .
if BD control box is connected between stock ECU connectors sled works on idling 5-20 seconds, and stopped absolutely like I turned off the ignition. Then If I connect all connectors like on stock to ECU ( w/o BD control box) sled will works normal.
If I will run 4000-5000 rpm by connected BD control box, sled will works normal, if I will run by full throttle sled will stop , like I turned of ignition.
I can’t to try run by stock ECU by full throttle , I will destroy engine with turbo w/o additional fuel , but on idling and by 4000-5000 rpm sled by stock ECU run absolutely normal.
What can I do to repair it?
Thanks advance
 
Feb 2, 2019
4
2
3
Ups:face-icon-small-hap I forgot that yesterday I replaced spark plugs to Denso w27es-zu , when I put stock Bpr9es ,
everything became good. I can’t to believe, but it is real. Denso works normal by stock ecu , and wrong by BD control box.
 
Premium Features