Anyone seen this before?

Aluminum.magnet

Member
Lifetime Membership
Premium Member
Nov 24, 2019
18
7
3
SW MT
Was putting a new rail on my alpha and put in a stiffer front spring 20200410_194405.jpg 20200410_194425.jpg
Went to put in new spring on the front track shock and noticed this 20201010_161720.jpg
And then the center shock 20201010_163758.jpg
Harder to see but same wear marks. Arctic cat puts the springs on is what the dealer told me. Don't know if I ever would have noticed this otherwise. There isn't enough clearance between the shock spring and piggy back. I left the shocks with the dealer and they agreed it wasn't right. Never touched the preload on the shocks other than the quick adjust. Any thoughts?
 
Dec 16, 2011
7
3
3
My spring hit my shock on my 2020 HC and I had one small chip in the pain on the rail also. I changed the front preload spring to one recommended to me by a shock rebuilder. He recommended a arctic cat 2704-229. When I put it on it was narrower diameter with plenty of clearance. I don't understand cat sometimes.
 
Nov 14, 2012
43
22
8
I too have this problem on both my track shocks. My dealer tells me cat hasn’t seen enough of them to do anything about it. This started happening within the first 300 km for me. A00AB431-019C-4A29-9A11-28BEAE225C59.jpeg 4A6B117F-ED0F-464D-81C2-9B0E8C4A26D9.jpeg
 

Aluminum.magnet

Member
Lifetime Membership
Premium Member
Nov 24, 2019
18
7
3
SW MT
My dealer said cat will replace the shocks. Not sure what it's classified as but will try and get my rail warrantied also since the shocks are faulty
 
Premium Features