• I've received emails and PM's asking me about "Group Buys" and promotions.

    A Group Buy here on SnoWestOnline.com would be a situation where a normal member (non vendor or mfg) personally collects orders from other members. That member then uses those orders to negotiate a better price with the Vendor/Mfg for HIS/HER "Group" of buyers.

    Here is an example of a viable "Group Buy"

    http://www.snowestonline.com/forum/showthread.php?t=269222

    A promotion that has the words "Group Buy" in the title is still a promotion, and from the rules that were handed down to me by Harris Publications is that non-advertisers cannot run promotions or open sales programs on the forums outside of the swapmeet.

    If a members wants to become a group buy manager, maintain a thread and collect the funds and negotiate a group buy... as a member, you are welcome to do that as long as you are not attached to the business of the vendor or Mfg.

    If you are a vendor/MFG and you want to offer an EXCLUSIVE "SnoWestOnline ONLY" promotion that is exclusive to snowest readers, please contact me and you'll be able to put it up in the Polaris forums.

    Also, before any vendors/mfgs get all "riled up" over this know that the moderators are strictly volunteers and do not receive a dime from any advertising $$ spent on this site.

    As ALWAYS, since DAY ONE of me becoming a moderator, I have pioneered, supported and encouraged vendors and mfgs in getting the word out to our readers with "New Product Announcements.

    Have a great season.

    From this point on, all vendors/mfg's promoting Pre-Season tiered sales programs, in the Polaris Forums, that are not paid advertisers will be appropriately moved to the swapmeet section of the forums.

    MH

Another Dragon Down! Help PLEASE!

Just to start this off its a 2009 Dragon 800 about 600 miles slp pipe and hps can... So went up Friday and long story short was sidehilling when all the sudden it bogged/died and then hit full throttle. At this point I was not on the throttle which I found really weird it jumped right out from under me and then died...

After getting it towed back started taking a look at it checked tps sensor, throttle bodies and cables and found nothing not to mention we were only able to get it to start by disconecting the kill switch at which point it only ran wide open even though the throttle bodies were closed!

I feel like it may be the ecu, voltage regulator, or maybe stuck open injector/injectors.

Has anyone had this issue or know what it might be the dealer cant look at it for 3 weeks so I want to give it my best shot at doing it myself so that I am not out that long! Thanks!
 

jgd

Well-known member
Lifetime Membership
Nov 26, 2007
468
65
28
Becker, MN
I'd start with the throttle cable. WD-40 is good for driving out moisture. Spray it in there and work it out. Good luck...
 

AKSNOWRIDER

Well-known member
Lifetime Membership
Dec 25, 2007
8,882
4,430
113
59
anchorage
sounds like the throttle is stuck wide open..and that the safety kill switch in the throttle lever is doing its job by killing the sled...pull the airbox and see if the throttle plates have something stuck holding them open....
 

rmkboxer

Well-known member
Lifetime Membership
Nov 26, 2007
2,598
323
83
43
Bonney lake WA
sounds like the throttle is stuck wide open..and that the safety kill switch in the throttle lever is doing its job by killing the sled...pull the airbox and see if the throttle plates have something stuck holding them open....

yep that is what I would do. has to be the throttle plates stuck open. or a huge air leak. injectors or ecm couldn't cause this
 
I'd start with the throttle cable. WD-40 is good for driving out moisture. Spray it in there and work it out. Good luck...

Throttle cables are fine it was the first thing I checked no sticking at all but thanks.

sounds like the throttle is stuck wide open..and that the safety kill switch in the throttle lever is doing its job by killing the sled...pull the airbox and see if the throttle plates have something stuck holding them open....

It is stuck wide open but the big question is why??? before disconnecting the kill switch the sled wouldnt start at all... I did pull the air box and took a hard look at the TB's and plates and everything seems to be working I looked with a mirror and felt around but nothing! My friend watching the TB's when I started said that there didnt seem to even be opening but who knows

And find a new dealer! 3 weeks ? Ridiculous.

Ya, I guess I have to depend on myself at this point its pretty frustrating! The only other local polaris dealer doesnt seem to do the best work even worse I am only about 1 month out of warranty.
 

rmkboxer

Well-known member
Lifetime Membership
Nov 26, 2007
2,598
323
83
43
Bonney lake WA
would you rather them take your sled in and then have it for 3 weeks, they are one of the best around here. pretty understandable with there reputation
 
I'm not talking down about them if thats what you guys are thinking! I would hands down prefer to take my sled there I just dont want to wait that long.

Please if you dont have any input on the original post then leave it out I am running out of ideas and could really use the help thanks again! :face-icon-small-coo
 

Clarke673

Somewhere between too dumb to quit and flat earth
Premium Member
Dec 2, 2007
3,101
447
83
Gardiner Montana
My 800 went down this weekend as well. Powdered the PTO side piston. Hopefully that is the only damage. I will find out tonight. Need to get it going before Christmas is hear! What sucks is i have no idea why it happened?
 

IQ?

Well-known member
Lifetime Membership
Nov 28, 2007
339
159
43
47
Vilhelmina,Sweden
www.facebook.com
My 800 went down this weekend as well. Powdered the PTO side piston. Hopefully that is the only damage. I will find out tonight. Need to get it going before Christmas is hear! What sucks is i have no idea why it happened?
Clarke67 do you have the Slp ecu?
I think its a must to get the twins to work
Mine is getting stronger every ride!
I have similar setup a yours maybe more porting on mine
I have heavy case port and cyl port with crazy high exh.
Port.
I can hold it at 5-6k in the dangerous midrange for 5 miles
On logging roads an pinned for 20 seconds! Without heat soak or
Detonation!!.not a chance with a stocker at sea level
At 5-6k rpm....
All with pumpgas at close to sea level 1800 feet.
Im gonna hook up autotune now and see what happens
It runs a little fat in some ranges.
Later
Ed
 

Outlaw525s

Member
Nov 19, 2010
130
24
18
ive always had the best deals at The Herreid Sporting Center In Herreid SD... They had my sled rebuilt in 3 hours and always had the best of luck.. Nice people. goood excellent machanics and are always bussy but still gets alot of stufff done.. If you have any problems then they go through your sled with a fine tooth comb and then some.. They always check the uncheckable.. and are verry reasonable priced..
 

rmkboxer

Well-known member
Lifetime Membership
Nov 26, 2007
2,598
323
83
43
Bonney lake WA
it has to be getting air from some where. if it was just fuel it would flood out and bog. I would think your intake boots are bad. I don't think a crank seal would do it. not enough air
 
Premium Features