850 is lacking power (BIG TIME)

Mar 7, 2019
4
0
1
hey guys,

Today was my first time out this year on my 2017 SKi Doo 850 TNT. I bought it new last year, and now its got 600 miles on it. Fuel was about 1/4 tank going in to summer storage. I burned a tank and a quarter today in just 50-60 miles!!

It has very limited power, just no "get up n go" what so ever. It tops out at 6500rpm and 67mph. Last year the thing ran like a raped ape! My buddy has the same sled and blew me away today.

i did notice back fire a few times. only backfired when i was nearing a stop as the RPMs were coming down.

im thinking bad spark plugs?
 

cubby

Well-known member
Premium Member
Nov 26, 2007
2,113
436
83
Not sure but doubt the plugs caused this. Maybe someone else will chime in on it but don't waste your money on plugs
 
Sep 9, 2013
80
44
18
hey guys,

Today was my first time out this year on my 2017 SKi Doo 850 TNT. I bought it new last year, and now its got 600 miles on it. Fuel was about 1/4 tank going in to summer storage. I burned a tank and a quarter today in just 50-60 miles!!

It has very limited power, just no "get up n go" what so ever. It tops out at 6500rpm and 67mph. Last year the thing ran like a raped ape! My buddy has the same sled and blew me away today.

i did notice back fire a few times. only backfired when i was nearing a stop as the RPMs were coming down.

im thinking bad spark plugs?
I'd bet on bad gas from sitting that long.
 
Sep 9, 2013
80
44
18
that was my thought also, but i've put over a tank through it and no improvement.

it really seems like its only running on one cylinder, but cant say for sure because ive never had an issue like this.
Yeah but unless you ran one tank completely through it and ran it dry I wouldn't dismiss it yet, usually is the simplest thing. Where did the 2nd tank come from? Hopefully bought fresh and not from tanks sitting in the garage also?

I haven't even looked for a fuel filter on mine yet but that could be gunked up?
 
Mar 7, 2019
4
0
1
Yeah but unless you ran one tank completely through it and ran it dry I wouldn't dismiss it yet, usually is the simplest thing. Where did the 2nd tank come from? Hopefully bought fresh and not from tanks sitting in the garage also?

I haven't even looked for a fuel filter on mine yet but that could be gunked up?
91 octane as usual from local gas station. I’ve never had 91 go bad so I’m skeptical of fuel degradation. I pulled the left plug and it looks spent. I’ve got two new plugs coming.

Evidently the plugs in a 2017 850 are rare. Nobody had them in stock. Should show up mid next week.

Cross your fingers
 
Premium Features