• I've received emails and PM's asking me about "Group Buys" and promotions.

    A Group Buy here on SnoWestOnline.com would be a situation where a normal member (non vendor or mfg) personally collects orders from other members. That member then uses those orders to negotiate a better price with the Vendor/Mfg for HIS/HER "Group" of buyers.

    Here is an example of a viable "Group Buy"

    http://www.snowestonline.com/forum/showthread.php?t=269222

    A promotion that has the words "Group Buy" in the title is still a promotion, and from the rules that were handed down to me by Harris Publications is that non-advertisers cannot run promotions or open sales programs on the forums outside of the swapmeet.

    If a members wants to become a group buy manager, maintain a thread and collect the funds and negotiate a group buy... as a member, you are welcome to do that as long as you are not attached to the business of the vendor or Mfg.

    If you are a vendor/MFG and you want to offer an EXCLUSIVE "SnoWestOnline ONLY" promotion that is exclusive to snowest readers, please contact me and you'll be able to put it up in the Polaris forums.

    Also, before any vendors/mfgs get all "riled up" over this know that the moderators are strictly volunteers and do not receive a dime from any advertising $$ spent on this site.

    As ALWAYS, since DAY ONE of me becoming a moderator, I have pioneered, supported and encouraged vendors and mfgs in getting the word out to our readers with "New Product Announcements.

    Have a great season.

    From this point on, all vendors/mfg's promoting Pre-Season tiered sales programs, in the Polaris Forums, that are not paid advertisers will be appropriately moved to the swapmeet section of the forums.

    MH

2015 Polaris Axys LED Headlight Issue

Jan 30, 2019
2
1
3
New to the forum and am learning lots already from what is posted here. I haven't come across a situation like the one I'm in so looking for help. I've got a 2015 SB Pro-S 600 with the sealed LED headlight unit. My right side (mag) low beam is either 'burned out' or it's barely visible/illuminated. Both high beams work just fine, so I wasn't sure if my resolution was to buy a new headlight unit or if it's a voltage regulator or wiring issue. Greatly appreciate any insight you guys may have, or what I can try to help eliminate certain things. My gauge stays illuminated and the handwarmers appear to be working as usual as well.
 
Jan 30, 2019
2
1
3
Wanted to let everyone that reads this know that it ended up being the headlight assembly. I bought a new one, hooked it up, and all headlights now work. For whatever reason, the LEDs only lasted 4 years and 2000 miles..
 
Premium Features