• I've received emails and PM's asking me about "Group Buys" and promotions.

    A Group Buy here on SnoWestOnline.com would be a situation where a normal member (non vendor or mfg) personally collects orders from other members. That member then uses those orders to negotiate a better price with the Vendor/Mfg for HIS/HER "Group" of buyers.

    Here is an example of a viable "Group Buy"

    http://www.snowestonline.com/forum/showthread.php?t=269222

    A promotion that has the words "Group Buy" in the title is still a promotion, and from the rules that were handed down to me by Harris Publications is that non-advertisers cannot run promotions or open sales programs on the forums outside of the swapmeet.

    If a members wants to become a group buy manager, maintain a thread and collect the funds and negotiate a group buy... as a member, you are welcome to do that as long as you are not attached to the business of the vendor or Mfg.

    If you are a vendor/MFG and you want to offer an EXCLUSIVE "SnoWestOnline ONLY" promotion that is exclusive to snowest readers, please contact me and you'll be able to put it up in the Polaris forums.

    Also, before any vendors/mfgs get all "riled up" over this know that the moderators are strictly volunteers and do not receive a dime from any advertising $$ spent on this site.

    As ALWAYS, since DAY ONE of me becoming a moderator, I have pioneered, supported and encouraged vendors and mfgs in getting the word out to our readers with "New Product Announcements.

    Have a great season.

    From this point on, all vendors/mfg's promoting Pre-Season tiered sales programs, in the Polaris Forums, that are not paid advertisers will be appropriately moved to the swapmeet section of the forums.

    MH

2012 rmk pro 800 fouled plugs

Jan 3, 2019
4
1
3
I had the engine rebuilt last year and put less than 50 miles on the sled. This year I started it up for the first time and it was running rough; seemed like it was running on one cylinder. I took it back to the shop that did the rebuild. They replaced the plugs and it was running fine for about a five mile test ride. I went to start it today and same problem. I replaced the plugs again. One plug was dry and brown. The other was black and wet. The guy at the shop told me that the oil pump was replaced during the rebuild and the engine is still breaking in. The sled ran fine for about 10 miles other than a hesitation when I tried to pin it one time. The next time I pinned it, there was no hesitation. I am questioning if everything is ok and worried about taking it for a long ride. Any feedback would be appreciated. Thanks
 
Premium Features