2012 pro RMK boondocker turbo with vipec

Oct 7, 2011
45
1
8
Bought this sled as a fixer upper. Sled is a 2012 pro RMK with a boondocker turbo. It has the vipec ecu on it.

Issue I am having is the sled “cuts out” at around 5-6000 rpm. Seems like it runs out of fuel. Mechanically all appears to be in good condition. There is a check engine light on and when I follow the instructions to read a code it comes up with a 1 where the rpm would be and a 1 where the odometer would be. Reading that as a code 11.
I would like to connect to the ecu but seem to be having issues doing so. I have a cord that fits the plug on the ecu (unless it is a special cord) and have downloaded multiple different versions of there software without any success to be able to connect. Does anyone have a contact who I could reach out to?

I’m running out of options and am almost to the point that I will be putting it back to stock.

Any help would be greatly appreciated.
 
Its a standard usb mini cable, nothing special. There will be two different software versions of VTS, the one you use depends on what version firmware is loaded to the ecu. Just try both if your not sure.

Are you trying to connect while the sled is running? Or are you powering up the ecu with a 12v battery?
 
Oct 7, 2011
45
1
8
Its a standard usb mini cable, nothing special. There will be two different software versions of VTS, the one you use depends on what version firmware is loaded to the ecu. Just try both if your not sure.

Are you trying to connect while the sled is running? Or are you powering up the ecu with a 12v battery?
I have tries both ways without much success.
 
Premium Features