2002 mountain cat 600 random die

Dec 20, 2016
152
34
28
31
Mapleton Utah
When out riding it dies as if you hit the kill switch after a couple hours of straight trail riding about 25 mph or so pulled and pulled on the rope 5 or six times. Pulled the plugs and couldnt tell if their was spark on a bright day. Put the plugs in and pulled a couple more times nothing as if the kill switch was off. I pulled it around down hill and was getting ready to start walking the six miles back to the truck and pulled two more times and it fired up and ran like it was loaded on fuel. It cleared up and I made it to the truck ran fine. It is a 2002 electric start 600 mountain cat LE.

Also when steadily riding at 15 mph I have a slight stumble or miss in the throttle.
 
Last edited:

triedit

Member
Premium Member
Dec 4, 2007
139
12
18
sheridan wy
first thing is to unhook kill switch on steering column,trace the wires from kill switch over to column might need to remove plastic cover mounted to top of tank,i think its a brown with purple wire . if that doesnt fix it then more and likely your stator ,there is a test procuder for them but it doesnt usually show the problem ,the only way to totally rule out the stator is to change it ,find another sled to borrow it from or by a used one on ebay,
 
Dec 20, 2016
152
34
28
31
Mapleton Utah
first thing is to unhook kill switch on steering column,trace the wires from kill switch over to column might need to remove plastic cover mounted to top of tank,i think its a brown with purple wire . if that doesnt fix it then more and likely your stator ,there is a test procuder for them but it doesnt usually show the problem ,the only way to totally rule out the stator is to change it ,find another sled to borrow it from or by a used one on ebay,
So i took it out again and it is a hard left I take and something cuts out and so I gotta chase all my wiring
 
Premium Features