• I've received emails and PM's asking me about "Group Buys" and promotions.

    A Group Buy here on SnoWestOnline.com would be a situation where a normal member (non vendor or mfg) personally collects orders from other members. That member then uses those orders to negotiate a better price with the Vendor/Mfg for HIS/HER "Group" of buyers.

    Here is an example of a viable "Group Buy"

    http://www.snowestonline.com/forum/showthread.php?t=269222

    A promotion that has the words "Group Buy" in the title is still a promotion, and from the rules that were handed down to me by Harris Publications is that non-advertisers cannot run promotions or open sales programs on the forums outside of the swapmeet.

    If a members wants to become a group buy manager, maintain a thread and collect the funds and negotiate a group buy... as a member, you are welcome to do that as long as you are not attached to the business of the vendor or Mfg.

    If you are a vendor/MFG and you want to offer an EXCLUSIVE "SnoWestOnline ONLY" promotion that is exclusive to snowest readers, please contact me and you'll be able to put it up in the Polaris forums.

    Also, before any vendors/mfgs get all "riled up" over this know that the moderators are strictly volunteers and do not receive a dime from any advertising $$ spent on this site.

    As ALWAYS, since DAY ONE of me becoming a moderator, I have pioneered, supported and encouraged vendors and mfgs in getting the word out to our readers with "New Product Announcements.

    Have a great season.

    From this point on, all vendors/mfg's promoting Pre-Season tiered sales programs, in the Polaris Forums, that are not paid advertisers will be appropriately moved to the swapmeet section of the forums.

    MH

17 axys dropping rpm

Nov 25, 2019
53
26
18
I posted a while back about installing a camso x3 on my sled.....since then I can’t maintain full rpm. On the trail my sled will hit 8400 but in deep powder it will peak at 8000-8250 then drop down to 7900-8000. Sometimes it will even drop to 7600rpm. When i was in mccall I swapped my 64g weights for 62g to see if it was an elevation issue.....didn’t help.
I had my sled at the dealer yesterday and had the tps re calibrated and a relearn on the exhaust valves. New plugs were installed the night before I took the sled to the dealer.

I’m going to change out the clutch springs and see if it helps........

Any advice/suggestions would be greatly appreciated.
 

Alaskanparret

Member
Nov 25, 2011
57
14
8
27
Primary spring could be broken but usually see more drastic rpm drops...

Stock belt? How many miles on the belt? The belts do wear out. Happened to me. RPM’s slowly dropped off. Finally blew that belt, new one made the sled come back to life.

Belt deflection good?

Recheck your motor mounts




Sent from my iPhone using Tapatalk Pro
 
Nov 25, 2019
53
26
18
Primary spring isn’t broken, deflection is good, belt has been changed twice, motor mounts might have 300km on them.
Stock sled minus track and jaws pipe.
 

Wintertime

Well-known member
Lifetime Membership
Apr 18, 2014
258
88
28
Casper, WY
How many miles on the sled?
Have the power valves been cleaned?
Pipe fitment is it sealed uptight? No blow-by.
Spark plug connections tight meaning if you tug on the caps they stay on the wires at the cap and coil they fit tight on the spark plug? Mine was loose in this area. (Thanks TRS)
All Relays and connections are clean and no corrosion in them?
The primary clutch is clean buttons are good, the cover bushing is in good shape?
Reeds are ok?

I have been down this road before and figured it out and a lot of the things I listed were checked and rechecked. One, my pipe had some blow-by bad donuts. Two plug wires. Three power valves. I also cleaned all connections and basically went through the whole sled. The dealers are almost useless when it comes to stuff like this. You have to use a systematic approach to this and write everything down you look at and elimatnate as you go. After some of these things my 17' ran like a top and never had any trouble. Sled had 2100 on the clock when sold.
 
Nov 25, 2019
53
26
18
Sled has 3500km on it. I’m going to clean power valves and open the secondary this week. Plug caps seem to be snug. Pretty sure the pipe/can seals are good.
I had an issue with the seal for the can and the issues it caused were nothing like this current issue. It would drop to 6800rpm with the can seal issue.
 
Nov 26, 2007
1,337
629
113
Elko, NV.
I also had the exact same issue, I also checked all the above with no result, dealer was completely useless. Give your primary rollers a good look, you will be lucky to get 1000 miles on a set of rollers. Provided the rollers look good I would try deglazing your primary clutch face and deglazing your best belt. With recommended stock clutching one of my Axys will pull 8,100 with the black secondary spring and one will not, I had to go to the black/purple. The stock 1183 belt is a heat fade nightmare, I've found the Gates Carbon 45C4553 will hold proper RPM much better. Good Luck, deglazing solved my issues.
 

kanedog

Undefeated mountain clutching champ of the world.
Lifetime Membership
Oct 14, 2008
2,033
1,718
113
56
With 3500kms the clutches need a rebuild. It’s not backshifting. That usually means something is binding or sticking.

If you got 3500kms without a clutch rebuild, thats really good.
 

Wintertime

Well-known member
Lifetime Membership
Apr 18, 2014
258
88
28
Casper, WY
That would be a good place to start. Didn’t know the miles in earlier post. A good rebuild and cleaning.


Sent from my iPhone using Tapatalk
 
Nov 25, 2019
53
26
18
The dealer looked over the primary and said it’s in really good shape given the km’s. I’ve cleaned the clutch sheaves and belt since the issue started. This issue is happening with both 1183 and the 115 belts( belt for the 14-15 pro rmk)
 

KFSNOW

Member
Lifetime Membership
Nov 26, 2007
66
14
8
My rpms were down 7900 went through everything, pulled power valves and left side valve bolt was missing so power valve was not opening. I cleaned them even though they looked really good for 1800 miles. We’ll see how it runs tomorrow.
 
Nov 25, 2019
53
26
18
I have a new primary and secondary spring coming mid week. Might put swap the secondary with my 14 and see what if it’s still dropping rpm. Exhaust valves will be checked this week as well.
 
Nov 25, 2019
53
26
18
Sled ran awesome on Thursdays ride but my new springs shows up so I’m going to try them out.

Installed the new clutch springs, SLP Blue/pink primary, EPI blue 160/280 secondary spring. Installed new bushings in my 10-64 weights and put them back in the primary. Test ride tomorrow, unfortunately it rained for 24hrs Friday/Saturday so I won’t get to test it in powder.
 
Premium Features