03 mxz no electrical please help.

AJSskidoo

New member
Jan 30, 2008
35
4
8
39
Minnesota
Hoping some one could help me out, Started sled up today to go for a short ride and noticed I have nothing working on the dash. No speedo,tach,warning lights, no headlight, tail light and no warmers. Tether key is on all the way runs fine, took it down the trail for 5 mins or so runs wide open fine what else could it be? both fuses I know of (on right side behind choke lever) are good. everything worked a week ago when I ran it around home and got it ready for season. Thanks for any input. Adam.
 

Snow Duck

The Great and Mighty SnowDuck
Staff member
Lifetime Membership
Aug 27, 2009
3,330
1,347
113
Kuna Idaho to Elk City Idaho..
Check all harness plugs to see if tight and pushed all the way in...then second...pull loom off wiring and make sure no rubbed spots evident...from hood connector to engine..
 

AJSskidoo

New member
Jan 30, 2008
35
4
8
39
Minnesota
I will check it thanks again. where would the most common spot be if its rubbed? hood hinge area I would guess?
 
Last edited:

AJSskidoo

New member
Jan 30, 2008
35
4
8
39
Minnesota
thanks guys I will look in both spots I also have a black circut breaker next to the fuses on right side wondering what that is or if that is what you guys are tlking about. In any case I will check both spots thanks again. Iguess they're bound to go out some time. they are only 7 YEARS OLD! :laugh::laugh:
 

AJSskidoo

New member
Jan 30, 2008
35
4
8
39
Minnesota
LET THERE BE LIGHT!!! thanks a million guys. My relay was located behind right side panel next to fuses napa #AR201 is the one! #AR143 relay comes with the mounting tab to screw it back to original spot. Thanks again. I bought 3.
 

skidoorevetec

New member
Dec 9, 2010
1
0
1
30
03 eltrical problem

its a relay under the hood right above the air box.. its like 35 bucks or you can get one at the auto parts for cheaper... but yea goodluck..
 

keneb

Member
Sep 3, 2010
31
7
8
Spokane WA
Funny, I just had the same problem. I found a nice firm "WHACK" with a screwdriver handle on the relay workes wonders! Though I did promptly get a few new ones when we got back home. :face-icon-small-hap
 

ape

Member
May 5, 2010
81
7
8
Prince George B.C.
Well thanks gang. I was loading up last night to go out today and no lights or dash. I thought the stator was shot but after looking through here found this thread and have now fixed the problem a lot cheaper than what I thought the price might be. I love this place.
 

summ8rmk

Too handsome
Lifetime Membership
Premium Member
Feb 16, 2008
10,892
4,314
113
yakima, wa.
This was the problem with my moms 03zx also. Thanks.
I went to autozone with the napa numbers above and got this, an A/C relay



GS6
 
Last edited:
Premium Features