For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: EDGE 2002-2005, all models in the Edge chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 05-18-2018, 10:43 PM
whoisthatguy's Avatar
whoisthatguy whoisthatguy is offline
Currently: Not set.
Join Date: Dec 2007
Posts: 579
Thanks: 6
Thanked 113 Times in 94 Posts
Rep Power: 9611269
whoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond repute
Default PERC Reverse does not function

My perc reverse button suddenly has stopped working on my Primary 04 RMK. I changed out the stator and it does not work on either the newer or old stator. I have 3 difference left handle perc reverse assemblies and they all seem to work on my backup 04 RMK, but none work on my primary 04 RMK. So it is not the perc reverse handle assembly. I have 3 different CDI boxes that I plugged in and that does not seem to make any difference either. I am running out of ideas for swapping components to find defective ones. Does anybody have any ideas for what else to look at? When I say it does not work, I mean the engine does not stop and restart going backward.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 05-18-2018, 11:47 PM
retiredpop retiredpop is offline
Currently: Not set
Join Date: Jul 2001
Location: Calgary
Posts: 1,074
Thanks: 97
Thanked 189 Times in 170 Posts
Rep Power: 8732232
retiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond repute
Default

I'm thinking a wiring problem is all that is left after what you have tried. Do you get a ground at the grey wire on the CDI when you push the button? I don't have a wiring diagram specifically for the RMK so am not positive on the wire color. The diagram I do have shows it on pin 22 at the CDI connector and the grey wire comes from the handlebar switch assembly. Ground is fed to the handlebar switch assembly on a brown wire and goes onto grey when the perc button is operated.
__________________
The older I get the better I was. In fact now that I think about it I'm a legend!

Haven't outgrown my 600 yet!
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to retiredpop For This Useful Post:
whoisthatguy (05-19-2018)
  #3  
Old 05-20-2018, 07:25 PM
whoisthatguy's Avatar
whoisthatguy whoisthatguy is offline
Currently: Not set.
Join Date: Dec 2007
Posts: 579
Thanks: 6
Thanked 113 Times in 94 Posts
Rep Power: 9611269
whoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond reputewhoisthatguy has a reputation beyond repute
Default

I followed the gray wire back to a 2 wire white plug that had become disconnected right next to the steering post. I plugged that connection back together and it now works fine.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to whoisthatguy For This Useful Post:
retiredpop (05-23-2018)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — perc reverse on 01 800 Thread Starter — ecut Forum — Polaris: EDGE Replies — 2 Last Post — 01-07-2018 10:13 PM
Thread — perc reverse for pro x Thread Starter — moose21 Forum — Polaris: EDGE Replies — 0 Last Post — 01-05-2011 07:02 PM
Thread — Perc reverse question ? Thread Starter — sirvilader Forum — Polaris Replies — 3 Last Post — 03-25-2009 08:22 AM
Thread — Used Perc reverse electrical Thread Starter — fastlane Forum — Clutch/Drive Train/Belt (Swapmeet) Replies — 2 Last Post — 02-02-2008 09:20 AM
Thread — Used Perc reverse electrical Thread Starter — fastlane Forum — Misc. Sled Parts Replies — 1 Last Post — 02-01-2008 10:47 PM

All times are GMT -6. The time now is 02:24 AM.