For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: Pro-Ride 2010 and up, all models in the Pro-Ride chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 04-22-2018, 07:19 PM
Turblue's Avatar
Turblue Turblue is offline
Currently: Sledding soon
Join Date: Jun 2004
Location: Alberta
Age: 43
Posts: 855
Thanks: 96
Thanked 186 Times in 79 Posts
Rep Power: 12300187
Turblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond repute
Default 12 600 Pro rmk hesitating fuel pump whine

So been fighting a intermittent problem with my sons 12 600 Pro Rmk. The sled ever once in a while starts cutting out under acceleration. I have also noticed a fuel pump whining noise at the same time when this happens. Yesterday had it happen...shut the sled off for 15 min or so and the noise went away. Guessing need to pull the fuel pump and see what’s going on in there. Also probably change the fuel filter, possibly hoses too. Any other suggestions?
Reply With Quote


Rate this post: Yes | No
  #2  
Old 04-23-2018, 11:29 AM
gtwitch gtwitch is offline
Currently: Not set.
Join Date: Jan 2011
Location: Laramie, Wyoming
Age: 76
Posts: 234
Thanks: 0
Thanked 82 Times in 56 Posts
Rep Power: 2544830
gtwitch has a reputation beyond reputegtwitch has a reputation beyond reputegtwitch has a reputation beyond reputegtwitch has a reputation beyond reputegtwitch has a reputation beyond reputegtwitch has a reputation beyond reputegtwitch has a reputation beyond reputegtwitch has a reputation beyond reputegtwitch has a reputation beyond reputegtwitch has a reputation beyond reputegtwitch has a reputation beyond repute
Default

Could this issue be caused by fuel level in tank? If so, check all of the items you mention. Pump could be sucking air because of a pickup hose ?? Just thinking around the outside of the box here!!
gtwitch in wyoming
Reply With Quote


Rate this post: Yes | No
  #3  
Old 04-23-2018, 11:46 AM
Turblue's Avatar
Turblue Turblue is offline
Currently: Sledding soon
Join Date: Jun 2004
Location: Alberta
Age: 43
Posts: 855
Thanks: 96
Thanked 186 Times in 79 Posts
Rep Power: 12300187
Turblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond repute
Default

Tank was pretty much full. Almost like it was starving from fuel.
Reply With Quote


Rate this post: Yes | No
  #4  
Old 04-23-2018, 12:36 PM
TRS's Avatar
TRS TRS is offline
Currently: Waiting for winter
Join Date: Dec 2007
Location: Cody, WY
Age: 61
Posts: 2,328
Thanks: 768
Thanked 2,103 Times in 764 Posts
Rep Power: 21474849
TRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond repute
Default

Were the outside temps fairly warm?
Reply With Quote


Rate this post: Yes | No
  #5  
Old 04-23-2018, 12:57 PM
Turblue's Avatar
Turblue Turblue is offline
Currently: Sledding soon
Join Date: Jun 2004
Location: Alberta
Age: 43
Posts: 855
Thanks: 96
Thanked 186 Times in 79 Posts
Rep Power: 12300187
Turblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond repute
Default

Yeah 50-60
Reply With Quote


Rate this post: Yes | No
  #6  
Old 09-18-2018, 08:47 PM
Turblue's Avatar
Turblue Turblue is offline
Currently: Sledding soon
Join Date: Jun 2004
Location: Alberta
Age: 43
Posts: 855
Thanks: 96
Thanked 186 Times in 79 Posts
Rep Power: 12300187
Turblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond repute
Default

Just bringing this back to light...never did find anything last spring. Only does the hesitation and fuel pump whine when the ambient temp is warm
Reply With Quote


Rate this post: Yes | No
  #7  
Old 10-20-2018, 06:08 AM
Turblue's Avatar
Turblue Turblue is offline
Currently: Sledding soon
Join Date: Jun 2004
Location: Alberta
Age: 43
Posts: 855
Thanks: 96
Thanked 186 Times in 79 Posts
Rep Power: 12300187
Turblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond repute
Default

So I believe I know why the hesitation and pump whine happens on the warm hard pack days...the coolant running in the hose and the tunnel coolers makes the gas so warm it causes the issue. Anyway installed DEI reflect-a-cool to hopefully aid in keeping the gas cool. This is the only logical reason why it affects these sleds on warm days. I will report back if it indeed cures the issue.

Reply With Quote


Rate this post: Yes | No
  #8  
Old 10-20-2018, 02:10 PM
73 Starfire 73 Starfire is offline
Currently: Not set.
Join Date: Dec 2007
Basic Member
Posts: 83
Thanks: 7
Thanked 15 Times in 9 Posts
Rep Power: 850506
73 Starfire has a reputation beyond repute73 Starfire has a reputation beyond repute73 Starfire has a reputation beyond repute73 Starfire has a reputation beyond repute73 Starfire has a reputation beyond repute73 Starfire has a reputation beyond repute73 Starfire has a reputation beyond repute73 Starfire has a reputation beyond repute73 Starfire has a reputation beyond repute73 Starfire has a reputation beyond repute73 Starfire has a reputation beyond repute
Default

Had a similar problem on a '08 600. Fuel pump whined and sled would not take over 1/4 throttle although temperature was not a factor. Turned out to be the fuel pickup hoses in the tank were ravaged by ethanol.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to 73 Starfire For This Useful Post:
Turblue (10-20-2018)
  #9  
Old 10-20-2018, 02:18 PM
Turblue's Avatar
Turblue Turblue is offline
Currently: Sledding soon
Join Date: Jun 2004
Location: Alberta
Age: 43
Posts: 855
Thanks: 96
Thanked 186 Times in 79 Posts
Rep Power: 12300187
Turblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond reputeTurblue has a reputation beyond repute
Default

Yeah this one only does it in the spring on warm day when my son is putting around. But not ruling anything out. Thanks for the info.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Pro RMK Gas Tank Fuel Pump Thread Starter — yotaman1290 Forum — Misc. Sled Parts Replies — 2 Last Post — 12-16-2015 11:24 AM
Thread — fuel pump whine Thread Starter — xmk1080 Forum — Polaris: Pro-Ride Replies — 3 Last Post — 03-25-2015 08:36 AM
Thread — Pro RMK Fuel pump Assy and pick up kit Thread Starter — Josh G Forum — Engine/Engine Parts (Swapmeet) Replies — 3 Last Post — 03-15-2015 02:27 PM
Thread — Anyone know what pressure the fuel pump on pro rmk is rated for? Thread Starter — snopromod Forum — Polaris: Pro-Ride Replies — 10 Last Post — 09-15-2013 08:56 PM

All times are GMT -6. The time now is 06:05 AM.

no new posts