For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: Pro-Ride 2010 and up, all models in the Pro-Ride chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 04-08-2018, 03:37 PM
huntfish64 huntfish64 is offline
Currently: Not set.
Join Date: Dec 2011
Location: Enumclaw, WA
Basic Member
Age: 34
Posts: 72
Thanks: 32
Thanked 5 Times in 3 Posts
Rep Power: 198967
huntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond repute
Default Code P0261 fix?

Code P0261.
Sled - 2015 RMK 600
Miles - 700 ish


This code has to do with the fuel injectors. What are the odds that the injector itself is bad? I have had the code cleared. Should I take it in and get fixed in the shop or....check wiring, check and clean connections, and send some injector cleaner through system? And just pray the code doesn't pop up again. It's my wife's sled, she is afraid of getting stranded way up on the hill. Any suggestions?
Reply With Quote


Rate this post: Yes | No
  #2  
Old 04-09-2018, 09:15 PM
diamonddave's Avatar
diamonddave diamonddave is offline
Currently: <<In-House PolarisTechnician not as involved in the shop
Join Date: Apr 2006
Location: Thieve Capital AKA Federal Way, WA.
Posts: 4,647
Thanks: 1,153
Thanked 1,482 Times in 866 Posts
Rep Power: 21474853
diamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond repute
Default

This is an ELECTRICAL fault with one (or both) of the injectors. It can be wiring related, injector related, or ECU related. (Related=Caused)

I have found quite a few this year with this issue and all have been defective injectors. But I would still check wiring very closely.

Given that these injectors develop excessive carbon deposits at early mileage due to the central location on the engine (SDI) I would highly recommend replacement. This issue has nothing to do with the trouble code just another good reason to replace them.

Sending injector cleaner will do nothing to solve this since the code is tripped due to an electrical fault and not a mechanical fault.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to diamonddave For This Useful Post:
huntfish64 (04-14-2018)
  #3  
Old 04-14-2018, 03:41 PM
huntfish64 huntfish64 is offline
Currently: Not set.
Join Date: Dec 2011
Location: Enumclaw, WA
Basic Member
Age: 34
Posts: 72
Thanks: 32
Thanked 5 Times in 3 Posts
Rep Power: 198967
huntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond reputehuntfish64 has a reputation beyond repute
Default

Thanks for the info. Is this going to keep happening after I get the injectors changed out? And if so, is there anything preemptive I can do so it doesn't happen again?
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Trouble Shooting P0261 Code - Injector Circuit Open Thread Starter — Slednut84 Forum — Polaris: Pro-Ride Replies — 0 Last Post — 02-07-2018 07:31 PM
Thread — CODE 06, CODE 66 FIX Thread Starter — hollywood506 Forum — Arctic Cat Replies — 1 Last Post — 04-11-2017 03:58 PM
Thread — Code 81, handwarmer, do I have to reset/clear the code? Thread Starter — snowmanx Forum — Nytros! Replies — 0 Last Post — 12-19-2016 03:34 PM
Thread — 2010 M8 Code 21 and Octn code keep coming on....? Thread Starter — gettis Forum — Arctic Cat: M Series Replies — 9 Last Post — 02-20-2013 03:39 PM
Thread — Nytro code problem... code 35... Thread Starter — Extreme-One Forum — Yamaha Replies — 4 Last Post — 01-02-2008 07:19 PM

All times are GMT -6. The time now is 05:07 PM.