For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: TURBO Turbo discussion for Polaris aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-24-2018, 09:03 PM
rockin rmk's Avatar
rockin rmk rockin rmk is offline
Currently: working
Join Date: Oct 2002
Location: Great Falls MT
Age: 47
Posts: 426
Thanks: 53
Thanked 18 Times in 15 Posts
Rep Power: 4226933
rockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond repute
Default 2016 polaris with silber runs rough in am.

When I start and let my sled warm up in the morning it seems to run rough like the plugs are fouled. engine doesn't sound normal either. once I get going it clears up and runs great the rest of the day. Would this be caused because coolant is not ran thru the throttle bodies anymore maybe they are icing up. Or could it be the mapping in ecu. blows out a lot of smoke also the first couple of times when I get on the gas.
__________________
16 Turbo Pro Axys 163
08 700 Dragon 163
07 600 RMK 155
87 Indy 400 136
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-25-2018, 10:07 AM
diamonddave's Avatar
diamonddave diamonddave is offline
Currently: <<In-House PolarisTechnician not as involved in the shop
Join Date: Apr 2006
Location: Thieve Capital AKA Federal Way, WA.
Posts: 4,647
Thanks: 1,153
Thanked 1,482 Times in 866 Posts
Rep Power: 21474853
diamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond repute
Default

How many miles on the sled? Have you tried a new set of plugs?

I worked on one that did this and installed the arctic Cat BR9EYA plugs and fixed the issue. Worked well for about 400 miles when it happened again and upon engine tear down found the piston rings were wasted.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to diamonddave For This Useful Post:
rockin rmk (03-26-2018)
  #3  
Old 03-25-2018, 01:06 PM
sumtinwong sumtinwong is offline
Currently: Not set.
Join Date: Oct 2016
Location: north pole alaska
Basic Member
Age: 39
Posts: 565
Thanks: 168
Thanked 121 Times in 89 Posts
Rep Power: 7521879
sumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond reputesumtinwong has a reputation beyond repute
Default

plugs are always a good start but they do have a tendency to load a bit in the morning do to the cold engine temps and long idle period to get them warm. if that's all the problem you have all day I would chalk it up to being boosted {mapping} on warm up.... if I remember right silber mentions that it might load on idle and says to just ride it out... ben a wile since I watched the vid. so don't quote me on that
Reply With Quote


1 out of 1 members found this post helpful. Rate this post: Yes | No
The Following 2 Users Say Thank You to sumtinwong For This Useful Post:
rockin rmk (03-26-2018), Wheel House Motorsports (03-25-2018)
  #4  
Old 03-26-2018, 08:43 AM
Sage Crusher's Avatar
Sage Crusher Sage Crusher is offline
Currently: easing into Winter......
Join Date: Dec 2010
Location: Rock Springs,Wyoming
Age: 61
Posts: 2,521
Thanks: 929
Thanked 591 Times in 397 Posts
Rep Power: 21474846
Sage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond repute
Default

Some of my clients Silber turbo sleds showed these signs of cold idle treats as yours.( loading up)
We started using the tether cord and had it pinched between the throttle block flipper opening- to help with the cold first idle... until I adjusted the TPS.
After adjusting it ( all sleds) -all cold idle issues went away- and never have come back in the past 2 years- NO more having to use the tether.. but it will work in a "pinch"- ( sorry for the pun) if you don't have the time to adjust, but that took care of ours..
__________________
Dealers for:
Silber Turbos.
GGB Exhaust.
TKI.
F-N-I.
K-Mod.
2016 Axys LTD 163 W/Silber Turbo/K-Mod Gen III/TKI
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to Sage Crusher For This Useful Post:
rockin rmk (03-26-2018)
  #5  
Old 03-26-2018, 07:24 PM
rockin rmk's Avatar
rockin rmk rockin rmk is offline
Currently: working
Join Date: Oct 2002
Location: Great Falls MT
Age: 47
Posts: 426
Thanks: 53
Thanked 18 Times in 15 Posts
Rep Power: 4226933
rockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond repute
Default

Quote:
Originally Posted by diamonddave View Post
How many miles on the sled? Have you tried a new set of plugs?

I worked on one that did this and installed the arctic Cat BR9EYA plugs and fixed the issue. Worked well for about 400 miles when it happened again and upon engine tear down found the piston rings were wasted.
Only 340 miles on sled. I have the ngk br9es plugs gapped at 18 thousandths
__________________
16 Turbo Pro Axys 163
08 700 Dragon 163
07 600 RMK 155
87 Indy 400 136
Reply With Quote


Rate this post: Yes | No
  #6  
Old 03-26-2018, 07:27 PM
rockin rmk's Avatar
rockin rmk rockin rmk is offline
Currently: working
Join Date: Oct 2002
Location: Great Falls MT
Age: 47
Posts: 426
Thanks: 53
Thanked 18 Times in 15 Posts
Rep Power: 4226933
rockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond repute
Default

Quote:
Originally Posted by Sage Crusher View Post
Some of my clients Silber turbo sleds showed these signs of cold idle treats as yours.( loading up)
We started using the tether cord and had it pinched between the throttle block flipper opening- to help with the cold first idle... until I adjusted the TPS.
After adjusting it ( all sleds) -all cold idle issues went away- and never have come back in the past 2 years- NO more having to use the tether.. but it will work in a "pinch"- ( sorry for the pun) if you don't have the time to adjust, but that took care of ours..
I will check the TPS I made a tool for my dragon I think it should work for this sled also.
__________________
16 Turbo Pro Axys 163
08 700 Dragon 163
07 600 RMK 155
87 Indy 400 136
Reply With Quote


Rate this post: Yes | No
  #7  
Old 03-26-2018, 07:36 PM
diamonddave's Avatar
diamonddave diamonddave is offline
Currently: <<In-House PolarisTechnician not as involved in the shop
Join Date: Apr 2006
Location: Thieve Capital AKA Federal Way, WA.
Posts: 4,647
Thanks: 1,153
Thanked 1,482 Times in 866 Posts
Rep Power: 21474853
diamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond reputediamonddave has a reputation beyond repute
Default

Quote:
Originally Posted by rockin rmk View Post
Only 340 miles on sled. I have the ngk br9es plugs gapped at 18 thousandths


BR9ES or BPR9ES?

If you are not running at least the BPR9ES (which is the stock plug) then you need to change immediately.

Better runnability, more crisp with the BR9EYA (Arctic Cat plug) and less plug fouling, when the ring wear in these 800 HO's begins to allow oil past the rings.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to diamonddave For This Useful Post:
rockin rmk (03-28-2018)
  #8  
Old 03-28-2018, 07:32 PM
rockin rmk's Avatar
rockin rmk rockin rmk is offline
Currently: working
Join Date: Oct 2002
Location: Great Falls MT
Age: 47
Posts: 426
Thanks: 53
Thanked 18 Times in 15 Posts
Rep Power: 4226933
rockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond repute
Default

Quote:
Originally Posted by diamonddave View Post
BR9ES or BPR9ES?

If you are not running at least the BPR9ES (which is the stock plug) then you need to change immediately.

Better runnability, more crisp with the BR9EYA (Arctic Cat plug) and less plug fouling, when the ring wear in these 800 HO's begins to allow oil past the rings.
Have the BPR9ES. Will try to find the other plugs and try them..
__________________
16 Turbo Pro Axys 163
08 700 Dragon 163
07 600 RMK 155
87 Indy 400 136
Reply With Quote


Rate this post: Yes | No
  #9  
Old 03-28-2018, 07:33 PM
rockin rmk's Avatar
rockin rmk rockin rmk is offline
Currently: working
Join Date: Oct 2002
Location: Great Falls MT
Age: 47
Posts: 426
Thanks: 53
Thanked 18 Times in 15 Posts
Rep Power: 4226933
rockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond reputerockin rmk has a reputation beyond repute
Default

Anyone have the TPS specs?
__________________
16 Turbo Pro Axys 163
08 700 Dragon 163
07 600 RMK 155
87 Indy 400 136
Reply With Quote


Rate this post: Yes | No
  #10  
Old 03-28-2018, 08:11 PM
Sage Crusher's Avatar
Sage Crusher Sage Crusher is offline
Currently: easing into Winter......
Join Date: Dec 2010
Location: Rock Springs,Wyoming
Age: 61
Posts: 2,521
Thanks: 929
Thanked 591 Times in 397 Posts
Rep Power: 21474846
Sage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond reputeSage Crusher has a reputation beyond repute
The Following User Says Thank You to Sage Crusher For This Useful Post:
rockin rmk (04-08-2018)
  #11  
Old 09-18-2018, 11:28 AM
Snowman.PRO. Snowman.PRO. is online now
Currently: Snowman.Pro
Join Date: Dec 2015
Basic Member
Age: 34
Posts: 45
Thanks: 31
Thanked 1 Time in 1 Post
Rep Power: 0
Snowman.PRO. is an unknown quantity at this point
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — M7 runs rough when warmed up with twins... Thread Starter — Snowmaker10 Forum — Arctic Cat: M Series Replies — 8 Last Post — 12-13-2015 05:23 PM
Thread — Engine runs rough Thread Starter — Caspers62 Forum — Polaris: Pro-Ride Replies — 0 Last Post — 03-04-2013 07:24 AM
Thread — 04 700 runs rough Thread Starter — 660popo Forum — Polaris: EDGE Replies — 11 Last Post — 01-23-2013 02:58 PM
Thread — Phazer runs rough Thread Starter — Flakey Forum — Phazers! Replies — 9 Last Post — 11-28-2011 11:49 PM
Thread — 09 Dragon runs rough?? Thread Starter — 09DragonRMK Forum — Polaris: IQ Replies — 3 Last Post — 12-19-2010 12:40 AM

All times are GMT -6. The time now is 02:07 PM.