For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: M Series 2005-Current, all models in the M-series chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-22-2018, 01:58 PM
Cwoods333 Cwoods333 is offline
Currently: Not set.
Join Date: Mar 2018
Basic Member
Age: 20
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Cwoods333 is an unknown quantity at this point
Question 2008 m8 engine cut out

I have a 2008 M8 and the engine cuts out(like hitting the kill switch) while letting off the throttle, once I let all the way off it comes right back on and acts like it is stuck in "high gear". Again once I let the rpms get back to normal idle and get going again it is fine. It randomly happens every 5-10 minutes. Any suggestions on things to check? The tss has already been disconnected.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-23-2018, 11:59 AM
jim jim is offline
Currently: Keyboard highmarking at its best.
Join Date: Nov 2007
Location: Boise
Posts: 696
Thanks: 48
Thanked 237 Times in 114 Posts
Rep Power: 0
jim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond repute
Default

Stuck in high gear? As in you stop the snowmobile and the idle is high? Or it just keeps moving forward and won't come to a stop?
Reply With Quote


Rate this post: Yes | No
  #3  
Old 03-28-2018, 09:49 PM
Cwoods333 Cwoods333 is offline
Currently: Not set.
Join Date: Mar 2018
Basic Member
Age: 20
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Cwoods333 is an unknown quantity at this point
Default

Once I let off it will continue to rev at 2500-3000 for a few seconds until i hit the throttle again.
Reply With Quote


Rate this post: Yes | No
  #4  
Old 03-28-2018, 09:55 PM
summ8rmk's Avatar
summ8rmk summ8rmk is online now
Currently: Alpha Hawk!
Join Date: Feb 2008
Location: yakima, wa.
Posts: 7,959
Thanks: 1,500
Thanked 767 Times in 346 Posts
Rep Power: 21474854
summ8rmk has a reputation beyond reputesumm8rmk has a reputation beyond reputesumm8rmk has a reputation beyond reputesumm8rmk has a reputation beyond reputesumm8rmk has a reputation beyond reputesumm8rmk has a reputation beyond reputesumm8rmk has a reputation beyond reputesumm8rmk has a reputation beyond reputesumm8rmk has a reputation beyond reputesumm8rmk has a reputation beyond reputesumm8rmk has a reputation beyond repute
Default

Frayed cable?
Catching sometimes?

Reply With Quote


Rate this post: Yes | No
  #5  
Old 03-29-2018, 09:24 AM
jim jim is offline
Currently: Keyboard highmarking at its best.
Join Date: Nov 2007
Location: Boise
Posts: 696
Thanks: 48
Thanked 237 Times in 114 Posts
Rep Power: 0
jim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond repute
Default

Check throttle function from cables to butterflies...make sure they are closing. Could be a lean condition from an air leak also.
Reply With Quote


Rate this post: Yes | No
  #6  
Old 03-29-2018, 01:56 PM
Cwoods333 Cwoods333 is offline
Currently: Not set.
Join Date: Mar 2018
Basic Member
Age: 20
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Cwoods333 is an unknown quantity at this point
Default

I've checked the throttle cable and everything seems to be moving correctly, It very tight at first so I loosened the cable and it is still happening.
Reply With Quote


Rate this post: Yes | No
  #7  
Old 03-30-2018, 06:55 AM
mbcat mbcat is offline
Currently: Not set.
Join Date: Mar 2011
Basic Member
Age: 42
Posts: 274
Thanks: 10
Thanked 24 Times in 23 Posts
Rep Power: 1650404
mbcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond repute
Default

Check spider in primary clutch closely for cracks. Sounds like it's goin on yah. When it acts up & you blip throttle the clutch frees up.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 2008 RMK 700 engine or compatible engine with chasis Thread Starter — bizzy4play Forum — Polaris Replies — 2 Last Post — 11-24-2015 09:42 AM
Thread — Custom kid sled with cut in half 800 polaris engine Thread Starter — NYPRO Forum — Member Sled Builds Replies — 1 Last Post — 11-30-2014 10:39 PM
Thread — To cut or not to cut (powderhound skis) Thread Starter — galljr13 Forum — Mountain/Deep Powder Replies — 1 Last Post — 01-14-2014 05:27 PM
Thread — Boondocker Turbo Pro Engine Cut out or Bog in Midrrange. Thread Starter — Hollywood99 Forum — Polaris: TURBO Replies — 3 Last Post — 02-13-2012 06:02 PM
Thread — 2008/9 IQR...What engine work is needed to make it a decent mountain engine? Thread Starter — mountainhorse Forum — Racing Replies — 4 Last Post — 07-23-2009 01:22 AM

All times are GMT -6. The time now is 05:32 AM.