For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: 900 05-06 Polaris RMK 900
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-17-2018, 12:40 PM
mann1921 mann1921 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 0
mann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond repute
Default throttle/tps issue 2005 rmk 900

Im having an issue with my throttle, and or tps and kill switch. When i would wiggle my throttle and kill switch the sled would die, in forward it will only rev to 2500 rpm but occasionally when it wiggles just right it will rev to like 4000, the sled runs fine in reverse but idles rough. what would be the issue here? Clutches are in good shape but I'm thinking its tps? or is there another thing to check?
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-17-2018, 12:58 PM
mountainhorse's Avatar
mountainhorse mountainhorse is offline
Currently: CONTEMPLATING: "Laughter is gods hand on a troubled world.".
Join Date: Dec 2005
Location: West Coast
Posts: 18,048
Thanks: 8,654
Thanked 9,310 Times in 4,120 Posts
Rep Power: 21474867
mountainhorse has a reputation beyond reputemountainhorse has a reputation beyond reputemountainhorse has a reputation beyond reputemountainhorse has a reputation beyond reputemountainhorse has a reputation beyond reputemountainhorse has a reputation beyond reputemountainhorse has a reputation beyond reputemountainhorse has a reputation beyond reputemountainhorse has a reputation beyond reputemountainhorse has a reputation beyond reputemountainhorse has a reputation beyond repute
Default

A couple of things.

I'm not really clear on your symptoms... but...

Check the tension/free-play on the Throttle lever... you need to have only .030 to .040 for the TSS (throttle saftey switch) to function correctly.

Second.. you could have issues with the TPS... the wires on the connector often go bad with no visible clue from the outside.

Lots of links to info in the tech section sticky.



.
__________________
.






Signature:
Reply With Quote


Rate this post: Yes | No
  #3  
Old 03-17-2018, 01:17 PM
mann1921 mann1921 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 0
mann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond reputemann1921 has a reputation beyond repute
Default

I have checked the wires well and have had the harness out for inspection and they check out. what part of the symptoms arnt clear? The sled boggs out at 2500 rpm in forward but not in reverse and when you mess with the throttle lever it will rarely run better but sometimes will kill it. The tss has two little pins and i have disconnected them and it just boggs out now.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Polaris THROTTLE BODY 1203505 IQ RMK IQ SWITCHBACK DRAGON WITH TPS 3131591 Thread Starter — tazmonster Forum — Fuels/Oils/Lubrication (Swapmeet) Replies — 0 Last Post — 07-05-2016 12:11 PM
Thread — Video For Tps Setting 2005 900 and 2006 700/900 CFi Thread Starter — mountainhorse Forum — Polaris: 900 Replies — 72 Last Post — 02-05-2014 04:14 AM
Thread — TPS on 900's checked at closed throttle position. Thread Starter — ttreewalkerr Forum — Polaris: 900 Replies — 1 Last Post — 09-14-2011 01:36 PM
Thread — throttle block issue - 2006 600 rmk Thread Starter — knee deep in it Forum — Polaris Replies — 3 Last Post — 04-20-2009 07:43 PM
Thread — 900 V-Force and Throttle body boot issue Thread Starter — diamonddave Forum — Polaris Replies — 2 Last Post — 10-27-2008 04:34 PM

All times are GMT -6. The time now is 05:34 AM.