For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: 900 05-06 Polaris RMK 900
Reply
 
Share Thread Tools Display Modes
  #1  
Old 02-10-2018, 07:17 AM
dman142 dman142 is offline
Currently: Not set.
Join Date: Nov 2008
Basic Member
Age: 41
Posts: 50
Thanks: 0
Thanked 4 Times in 3 Posts
Rep Power: 58811
dman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant future
Default Stator bolts

Has anyone ever had problems with the stator bolts backing out or shearing off? So far in 700 miles, the stator bolts have either broke off or backed out 5 times. I've been able to limp home each time with nearly no electrical system function. Stator is really getting beat up but still works great.

There's not other issues with the motor I feel. Runs really good, vibrations are not bad under load, clutch is in really good shape.

I have tried almost everything to fix the problem. Loctite hasn't worked, stronger bolts, weaker bolts, lock washers, and epoxy. Epoxy on the bolts and stator mount worked the best--about 200 miles.

I ended up with studs in the case instead of bolts. This way, I can use lock nuts in an attempt to hold the stator on. Probably either need a new case or part out the sled. I'm done with it after this.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 02-10-2018, 11:28 AM
dman142 dman142 is offline
Currently: Not set.
Join Date: Nov 2008
Basic Member
Age: 41
Posts: 50
Thanks: 0
Thanked 4 Times in 3 Posts
Rep Power: 58811
dman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant futuredman142 has a brilliant future
Default

I should also mention the crank runout is .0005 so I don't think that is an issue.
I have a extra hd clutch with the starter ring. Think this would help with balance?
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — stator bolts sheared off Thread Starter — DoubleYou Forum — Polaris: 900 Replies — 0 Last Post — 02-21-2014 08:09 PM
Thread — WTB stator ac 800/900 efi stator Thread Starter — Zip Forum — Engine/Engine Parts (Swapmeet) Replies — 1 Last Post — 01-13-2010 12:12 AM
Thread — Need Ducati CDI Stator Plugs (Dead Stator Needed) Thread Starter — Eli Forum — Engine/Engine Parts (Swapmeet) Replies — 0 Last Post — 01-05-2010 01:21 PM
Thread — stator # 4060213 * bad stator ? how 2 trouble shoot * Thread Starter — christian Forum — Polaris: GEN 2 Replies — 0 Last Post — 11-24-2009 10:16 AM
Thread — case bolts, head bolts, cyl nuts, head bolts Pol smallblock ves Thread Starter — moresnow Forum — WTB (Swapmeet) Replies — 4 Last Post — 06-19-2009 09:30 AM

All times are GMT -6. The time now is 10:07 AM.

no new posts