For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: 900 05-06 Polaris RMK 900
Reply
 
Share Thread Tools Display Modes
  #1  
Old 01-07-2018, 06:35 PM
7danie49 7danie49 is offline
Currently: patiently waiting for snow!
Join Date: Nov 2015
Basic Member
Age: 23
Posts: 27
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 0
7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute
Default New stator, no dash at idle

My dash turns off when the sled is idling, but turns on when the smallest amount of throttle is applied. The headlight remains on at idle. The sled idles around 1400 (I think, I can't exactly see), when the RPM is 1500 the dash turns on but blinks low voltage.

I just replaced the stator with a brand new aftermarket stator, but the tolerances aren't quite as tight as the manual. I found the stator on eBay and the description is copied and pasted from rmstators website, so I figured it was from quality from rmstator as I’ve read on here.

The sled runs great with the new stator. I put 10 miles on the sled before the dash cut out at idle, before that the dash was working like normal. I’m looking for suggestions on what to try next. Try a different stator or did something else fail in 10 miles?

Link to stator:
https://www.ebay.com/itm/Stator-For-...BaAbfS&vxp=mtr
Reply With Quote


Rate this post: Yes | No
  #2  
Old 01-08-2018, 12:08 AM
retiredpop retiredpop is offline
Currently: Not set
Join Date: Jul 2001
Location: Calgary
Posts: 1,077
Thanks: 97
Thanked 190 Times in 171 Posts
Rep Power: 8946981
retiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond repute
Default

Check the sticky in the Polaris section for the 900's. Particularly the one on chassis power connectors,
relays and grounds. Tons of good info in there.
https://www.snowest.com/forum/showthread.php?t=156763

https://www.snowest.com/forum/showthread.php?t=73220
__________________
The older I get the better I was. In fact now that I think about it I'm a legend!

Haven't outgrown my 600 yet!
Reply With Quote


Rate this post: Yes | No
  #3  
Old 01-08-2018, 03:32 AM
guidoxpress's Avatar
guidoxpress guidoxpress is offline
Currently: Tearing up Alaskas BOMB POW
Join Date: Jul 2008
Location: Wasilla, AK from MT
Age: 37
Posts: 5,084
Thanks: 2,580
Thanked 1,322 Times in 936 Posts
Rep Power: 21474852
guidoxpress has a reputation beyond reputeguidoxpress has a reputation beyond reputeguidoxpress has a reputation beyond reputeguidoxpress has a reputation beyond reputeguidoxpress has a reputation beyond reputeguidoxpress has a reputation beyond reputeguidoxpress has a reputation beyond reputeguidoxpress has a reputation beyond reputeguidoxpress has a reputation beyond reputeguidoxpress has a reputation beyond reputeguidoxpress has a reputation beyond repute
Garage
Default

Sounds like a capacitor issue to me.

Read the stickies in testing it. It’s super easy and shows immediate defect or not. They are super easy to find and replace.
__________________
"Too much, is not enough"

3 2016 Polaris AXYS.
06 RMK 900
His and Hers 16 badass AXYS builds
Reply With Quote


Rate this post: Yes | No
  #4  
Old 01-09-2018, 06:15 PM
7danie49 7danie49 is offline
Currently: patiently waiting for snow!
Join Date: Nov 2015
Basic Member
Age: 23
Posts: 27
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 0
7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute
Default

Thanks guido and pop,

I tested the capacitor, it's all good. I ran 12vdc through the chasis relay, it clicks opening the circuit and the circuit doesn't have any resistance, so it's all good.

I re-cleaned the ground, checked all the wires I could see, unplugged hand warmers/brake light/kill switch, even retested the stator, but nothing.

Dash flashes on when it first turns over, but isn't on at idle. Any other ideas?
Reply With Quote


Rate this post: Yes | No
  #5  
Old 01-09-2018, 08:17 PM
NapaMatt's Avatar
NapaMatt NapaMatt is offline
Currently: Stocking shelves, Need Parts??
Join Date: Mar 2009
Location: Stewartville, MN
Age: 33
Posts: 4,773
Thanks: 1,185
Thanked 409 Times in 304 Posts
Rep Power: 21474850
NapaMatt has a reputation beyond reputeNapaMatt has a reputation beyond reputeNapaMatt has a reputation beyond reputeNapaMatt has a reputation beyond reputeNapaMatt has a reputation beyond reputeNapaMatt has a reputation beyond reputeNapaMatt has a reputation beyond reputeNapaMatt has a reputation beyond reputeNapaMatt has a reputation beyond reputeNapaMatt has a reputation beyond reputeNapaMatt has a reputation beyond repute
Garage
Default

Did you replace the capacitor? ?

Always replace!

Did u glue in the inner ring/ was it loose in flywheel?
__________________
FOR SALE... SLP Pipe Set For Pro RMK 800... PM. Me for Details BRAND NEW 2013 ASSAULT PIGGY BACK FRONT SHOCKS FOR SALE!! $$650!!! Gas Tank From a 07 Switchback/ Seat Red and Black No tears. Plus fuel lines.
http://www.napaonline.com/
Theye Supply 1-507-533-6610
Auto Parts, Snowmobile, ATV, Truck and Trailer.. and
Shop Local!!
Reply With Quote


Rate this post: Yes | No
  #6  
Old 01-10-2018, 11:02 AM
retiredpop retiredpop is offline
Currently: Not set
Join Date: Jul 2001
Location: Calgary
Posts: 1,077
Thanks: 97
Thanked 190 Times in 171 Posts
Rep Power: 8946981
retiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond repute
Default

Maybe not your problem but the spec for idle rpm is 1700 plus or minus 200 so you are a but low. What AC voltage do you read on the yellow to ground at idle?
__________________
The older I get the better I was. In fact now that I think about it I'm a legend!

Haven't outgrown my 600 yet!
Reply With Quote


Rate this post: Yes | No
  #7  
Old 01-10-2018, 03:23 PM
7danie49 7danie49 is offline
Currently: patiently waiting for snow!
Join Date: Nov 2015
Basic Member
Age: 23
Posts: 27
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 0
7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute
Default

Quote:
Originally Posted by retiredpop View Post
Maybe not your problem but the spec for idle rpm is 1700 plus or minus 200 so you are a but low. What AC voltage do you read on the yellow to ground at idle?
The 05 manual for the 900 says 1400 rpm +- 200. And I believe the only way to change the idle rpm is by resetting the TPS. Am I wrong about this?

Are you talking about measuring the voltage from the yellow wires from the stator while idling? Or what yellow wire?
Reply With Quote


Rate this post: Yes | No
  #8  
Old 01-10-2018, 04:01 PM
retiredpop retiredpop is offline
Currently: Not set
Join Date: Jul 2001
Location: Calgary
Posts: 1,077
Thanks: 97
Thanked 190 Times in 171 Posts
Rep Power: 8946981
retiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond repute
Default

Quote:
Originally Posted by 7danie49 View Post
The 05 manual for the 900 says 1400 rpm +- 200. And I believe the only way to change the idle rpm is by resetting the TPS. Am I wrong about this?

Are you talking about measuring the voltage from the yellow wires from the stator while idling? Or what yellow wire?
Yes you have to reset the TPS idle voltage. I didn't realize the 05 was a different idle speed from the 06. It makes me wonder why the difference though because the idle screw on the throttle bodies should be set for .920 to .940 volts with .930 being the target for both years.

Yes measure on the yellow wires from the stator. If you can get one probe of the meter bridged onto the wire without disconnecting the connector that would be good.
__________________
The older I get the better I was. In fact now that I think about it I'm a legend!

Haven't outgrown my 600 yet!
Reply With Quote


Rate this post: Yes | No
  #9  
Old 01-10-2018, 04:44 PM
7danie49 7danie49 is offline
Currently: patiently waiting for snow!
Join Date: Nov 2015
Basic Member
Age: 23
Posts: 27
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 0
7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute
Default

Quote:
Originally Posted by retiredpop View Post
Yes measure on the yellow wires from the stator. If you can get one probe of the meter bridged onto the wire without disconnecting the connector that would be good.
Any recommendation on how to get to the stator connectors with the gas tank connected? Do we know what voltage the stator should send through these yellow wires?

Last edited by 7danie49; 01-10-2018 at 04:47 PM.
Reply With Quote


Rate this post: Yes | No
  #10  
Old 01-10-2018, 06:11 PM
7danie49 7danie49 is offline
Currently: patiently waiting for snow!
Join Date: Nov 2015
Basic Member
Age: 23
Posts: 27
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 0
7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute
  #11  
Old 01-10-2018, 07:31 PM
retiredpop retiredpop is offline
Currently: Not set
Join Date: Jul 2001
Location: Calgary
Posts: 1,077
Thanks: 97
Thanked 190 Times in 171 Posts
Rep Power: 8946981
retiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

  #12  
Old 01-10-2018, 10:23 PM
7danie49 7danie49 is offline
Currently: patiently waiting for snow!
Join Date: Nov 2015
Basic Member
Age: 23
Posts: 27
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 0
7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

  #13  
Old 01-11-2018, 07:30 PM
retiredpop retiredpop is offline
Currently: Not set
Join Date: Jul 2001
Location: Calgary
Posts: 1,077
Thanks: 97
Thanked 190 Times in 171 Posts
Rep Power: 8946981
retiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

The Following User Says Thank You to retiredpop For This Useful Post:
7danie49 (01-11-2018)
  #14  
Old 01-12-2018, 12:01 AM
7danie49 7danie49 is offline
Currently: patiently waiting for snow!
Join Date: Nov 2015
Basic Member
Age: 23
Posts: 27
Thanks: 4
Thanked 4 Times in 4 Posts
Rep Power: 0
7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute7danie49 has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 2015 Pro high idle, will die at idle, engine light on...... Thread Starter — devomx302 Forum — Polaris: Pro-Ride Replies — 3 Last Post — 12-24-2015 06:24 PM
Thread — Holeshot Dash Bag or Skinz Dan Adams Next Level Dash Bag Thread Starter — Cowboy357 Forum — Mountain/Deep Powder Replies — 6 Last Post — 09-28-2014 03:58 PM
Thread — Skinz Dan Adams Next Level Dash Bag or Holeshot Dash Bag Thread Starter — Cowboy357 Forum — Ski-Doo: XM Sleds Replies — 11 Last Post — 09-22-2014 06:47 AM
Thread — High idle then backfire then normal idle? Thread Starter — Cerialsledder Forum — Polaris: 900 Replies — 0 Last Post — 03-22-2013 01:53 PM
Thread — low idles, bad idle, no idle Thread Starter — 9 Iron Forum — Ski-Doo: XP Sleds Replies — 0 Last Post — 01-28-2010 02:09 AM

All times are GMT -6. The time now is 02:16 PM.

no new posts