For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: Powder Special and older 2000 and older, all models in the Powder Special chassis and older chassis models
Reply
 
Share Thread Tools Display Modes
  #1  
Old 01-05-2018, 08:18 PM
Proteus88 Proteus88 is offline
Currently: Not set.
Join Date: Jan 2018
Basic Member
Age: 30
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Proteus88 is an unknown quantity at this point
Question Noob Help: Backfire and Bog down when accelerating

Hi Everyone,

I bought my first snowmobile this week: 2006 Panther 370.

Within about 5 minutes of it driving fine (and after warming up for about 10-15 minutes) when I throttle to more than a slow speed it backfires once every couple minutes and loses acceleration (bogs?) for a split second.

I checked the spark plugs and noticed under the fuel pump there appears to be some fuel (leak?)

The previous owner disconnected and then reconnected the kill switch however the key does not stop the engine when turned to off (have to use kiss switch)

I wonder, could it be the leaky fuel pump line? Would there be enough fuel that it idles fine and drives slow great but when I accelerate it isnt getting enough?

This is my first snowmobile and I've never fixed one before so all suggestions appreciated, thanks!
Reply With Quote


Rate this post: Yes | No
  #2  
Old 01-06-2018, 09:09 AM
Sledbrain2 Sledbrain2 is online now
Currently: Not set.
Join Date: Dec 2007
Location: Elkhorn NE
Basic Member
Posts: 973
Thanks: 72
Thanked 121 Times in 101 Posts
Rep Power: 5366346
Sledbrain2 has a reputation beyond reputeSledbrain2 has a reputation beyond reputeSledbrain2 has a reputation beyond reputeSledbrain2 has a reputation beyond reputeSledbrain2 has a reputation beyond reputeSledbrain2 has a reputation beyond reputeSledbrain2 has a reputation beyond reputeSledbrain2 has a reputation beyond reputeSledbrain2 has a reputation beyond reputeSledbrain2 has a reputation beyond reputeSledbrain2 has a reputation beyond repute
Default

could be staving fuel, if you are using all the fuel in the float bowl before the pump can fill it should act like its running out of gas. The back fire could also be an interment spark where gas vapors build up in combustion chamber when spark shuts off then fires. I would fix the leaky fuel line first, then move on to the wiring.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 02-04-2018, 03:50 PM
jackbombay jackbombay is offline
Currently: Not set.
Join Date: Mar 2017
Location: Eastern Idaho
Basic Member
Age: 45
Posts: 196
Thanks: 34
Thanked 70 Times in 42 Posts
Rep Power: 5032833
jackbombay has a reputation beyond reputejackbombay has a reputation beyond reputejackbombay has a reputation beyond reputejackbombay has a reputation beyond reputejackbombay has a reputation beyond reputejackbombay has a reputation beyond reputejackbombay has a reputation beyond reputejackbombay has a reputation beyond reputejackbombay has a reputation beyond reputejackbombay has a reputation beyond reputejackbombay has a reputation beyond repute
Default

Is the fuel pump is an aluminum disc about 2 inches in diameter and 1/2" thick? You can get rebuild kits for them, easy to instal, new diaphragms and o-rings.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 2003 600 rmk bog/backfire-PLEASE HELP! Thread Starter — sledheader Forum — Polaris: EDGE Replies — 7 Last Post — 11-30-2015 08:43 AM
Thread — backfire bog no reverse 05 900 Thread Starter — rmkpaintking Forum — Polaris: 900 Replies — 8 Last Post — 02-27-2015 12:35 PM
Thread — Popping when accelerating hard Thread Starter — craighardy Forum — Arctic Cat: 1100 ProClimb Replies — 5 Last Post — 11-12-2012 09:26 PM
Thread — 900 bog/backfire/idle Thread Starter — yort600 Forum — Polaris: 900 Replies — 10 Last Post — 03-05-2012 12:50 PM
Thread — 2008 M8, off idle bog and backfire Thread Starter — M8fever Forum — Arctic Cat: M Series Replies — 5 Last Post — 01-29-2010 03:07 PM

All times are GMT -6. The time now is 08:17 AM.

no new posts