For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: TURBO Turbo discussion for Arctic Cat aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-13-2017, 02:26 PM
tjcatman tjcatman is offline
Currently: Not set.
Join Date: Jan 2008
Location: Greenville Ca.
Age: 51
Posts: 369
Thanks: 6
Thanked 36 Times in 23 Posts
Rep Power: 2661725
tjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond repute
Question tubro tuning

So I live in Northern California and am looking for someone or recommendations on someone who can help me get a major bug out of my turbo. 2010 M8 153 with a Boondocker RG turbo. Sled keeps stalling/stuttering between 3500-4800 rpms to the point that it will almost put me over the handlebars. I have changed reeds, numbers, throttle block etc. and am unable to find the culprit. I do realize that I may need to drive out of state to accomplish this so Idaho or nearby would be my first choice. Again looking for experienced tuner that can help me out. Any advise would be greatly appreciated as well. Thanks
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-13-2017, 05:02 PM
jim jim is offline
Currently: Keyboard highmarking at its best.
Join Date: Nov 2007
Location: Boise
Posts: 696
Thanks: 48
Thanked 237 Times in 114 Posts
Rep Power: 0
jim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond repute
Default

I have an 09 M8 PG set-up. I would have this problem from time to time...and nothing I did cleared it up. I finally realized that my sled was only doing this after periods of longer idle time (5 seconds plus) and my motor was loading up a bit...getting rich and would stutter and not get on the pipe...just bog down once is started. I figured out that my sled was inhaling a bunch of hot air under the hood from an under-hood intake and this would put it past rich and it wouldn't recover. I put a snorkel on my intake and have a cold air intake. Never had the problem again after I did that. And I know for a fact that the race gas set-ups are worse-off for doing that. Something to think of. For some reason, with the boondocker set-ups, once they get rich in this range from hot air, they don't recover. Also, I fought a bad EBC unit for a bit that would do weird things. You might send that in to Boondocker and get it double checked. My sled runs great all day now.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 03-14-2017, 09:40 AM
tjcatman tjcatman is offline
Currently: Not set.
Join Date: Jan 2008
Location: Greenville Ca.
Age: 51
Posts: 369
Thanks: 6
Thanked 36 Times in 23 Posts
Rep Power: 2661725
tjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond reputetjcatman has a reputation beyond repute
Default Turbo

Thanks for the info. I have run a cold air intake since I bought the turbo. I'll check on the EBC not aware of any issues with it. What should I look for?
Reply With Quote


Rate this post: Yes | No
  #4  
Old 03-14-2017, 02:27 PM
jim jim is offline
Currently: Keyboard highmarking at its best.
Join Date: Nov 2007
Location: Boise
Posts: 696
Thanks: 48
Thanked 237 Times in 114 Posts
Rep Power: 0
jim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond repute
Default

My EBC was acting a bit erratic...Wouldn't keep the same screen mode up for long, the PSI couldn't be adjusted with anything but the elevation setting and when it really started to go out, my sled would completely fall on its face during boost up because the EBC wasn't sending the boost signal to the controller...would get a huge lean bog. It was also hard to tune...just seemed to vary all the time and required constant tuning. Now, it's pull and go. I can ride all day with minimal tuning...if any at all.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 3rd ANNUAL TUBRO DAYS Thread Starter — MCSD409 Forum — Polaris: TURBO Replies — 7 Last Post — 12-12-2011 09:07 PM
Thread — Boyesen Polaris Pro-RMK Tubro/ Race Reeds Thread Starter — skibum_1260 Forum — Carb/Airbox/Reeds (Swapmeet) Replies — 0 Last Post — 12-01-2011 05:12 PM
Thread — Tuning Help Please Thread Starter — Radski30 Forum — Yamaha: Boosted Sleds (Turbo or Supercharged) Replies — 24 Last Post — 12-03-2010 04:49 PM
Thread — Anybody make there own Tubro Kits? Thread Starter — brahm Forum — Performance/Modified Replies — 31 Last Post — 12-05-2009 12:39 AM
Thread — 09 Tubro M1000 Sno Pro Thread Starter — twsandrew Forum — Arctic Cat (Swapmeet) Replies — 2 Last Post — 03-29-2009 07:09 PM

All times are GMT -6. The time now is 07:53 AM.