For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Ski-Doo: REV Sleds 2004.5-200, all models in the REV chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 12-17-2016, 06:10 PM
wreckmaster wreckmaster is offline
Currently: Waiting for snow.
Join Date: Nov 2007
Location: RENNER SD
Basic Member
Age: 36
Posts: 109
Thanks: 8
Thanked 7 Times in 4 Posts
Rep Power: 188913
wreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond repute
Default 07 800r Hesitation and check engine light flash.

Hey

My nephew bought an 07 800r Adrenaline last week. The sled has 815 miles on it as well as a rebuilt motor. I took it for a test ride the other night and it has a hesitation when burping the throttle (any speed or rpm range) and the check engine light flashes/beeps at around 8,000 ish rpm. I went through the carbs, checked all the adjustments (jets, needle position, air screw 1 1/2 turns out) and gave it a good cleaning. I still have the same issues as the first test run. Other than those couple issues the sled runs really good. I was thinking about putting fresh gas in because I am sure it has fuel from last year in it.

Does anyone have any suggestions? I'm not sure where to go from here?


Thanks
wreckmaster
Reply With Quote


Rate this post: Yes | No
  #2  
Old 01-09-2017, 03:08 PM
Walleye65 Walleye65 is offline
Currently: Not set.
Join Date: Nov 2014
Age: 52
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Walleye65 is an unknown quantity at this point
Default

Just got done chasing down same problem in my 07. I pulled caps off of power valves...lifted back of sled and ran throttle. they were working completely backwards. At idle they went full out and stayed there. Found unhooked solenoid. Got all that straightened out....valves immediately worked properly (at idle they are sucked in, at rest during mid-range, all the way open at full throttle). All my beeps and lights went away..and sled really woke up.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 01-31-2017, 06:49 PM
wreckmaster wreckmaster is offline
Currently: Waiting for snow.
Join Date: Nov 2007
Location: RENNER SD
Basic Member
Age: 36
Posts: 109
Thanks: 8
Thanked 7 Times in 4 Posts
Rep Power: 188913
wreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond reputewreckmaster has a reputation beyond repute
Default

Yep. That was almost the same problem. One of the wires was unpinned from the power valve solenoid connector. It took a bit to notice it. Probably rattled loose. It's running good now.

Thanks for the reply.

wreckmaster
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Skidoo XP 800R Ptek Check Engine Light with 3Beeps Thread Starter — newbb Forum — Ski-Doo: XP Sleds Replies — 5 Last Post — 12-02-2016 06:04 PM
Thread — M7 Check Engine CE light: flash 6 times Thread Starter — kartorium Forum — Arctic Cat: M Series Replies — 1 Last Post — 01-06-2013 05:37 PM
Thread — 2 flash Engine Light Thread Starter — ippielb Forum — Arctic Cat Replies — 0 Last Post — 04-04-2011 07:43 PM
Thread — 2006 M7 check engine light flash Thread Starter — BigRed118 Forum — Arctic Cat: M Series Replies — 3 Last Post — 01-03-2010 03:46 PM
Thread — check engine light constant flash m7 Thread Starter — squirrel Forum — Arctic Cat Replies — 11 Last Post — 06-12-2008 09:46 PM

All times are GMT -6. The time now is 06:15 PM.