For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: Pro-Ride 2010 and up, all models in the Pro-Ride chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 12-30-2018, 07:27 PM
Mcp123 Mcp123 is offline
Currently: Not set.
Join Date: Oct 2018
Basic Member
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Mcp123 is an unknown quantity at this point
Default 600 Assault SLP not pulling RPMs

2016 Assault 600 with an SLP stage 3 is not pulling RPMs. 420 miles.. it has

SLP full exhaust
SLP high flow intake
Vforce 3R reeds
Power commander (SLP map)

Clutching:
140/340 primary (recommended by SLP)
SLP Magnum adjustable weights
140/220 secondary spring
NSP helix (not sure on angles)

At 1500 feet.. this sled should pull 8200 with 64 gram weights, all stock. After reading a lot , many said adding 2g of weight should get you to the recommended SLP RPM (8300). Obviously the added power should turn some more R's. I've also spoke to a few running this kit on 600s with no issues getting the peak rpm.

So... Shooting for 8300 RPM, here's what I'm getting:
62.6 g=8150
64g=7950-8000 <--- 200 RPM short of what stock should be
66g=7800. <--- this is where I expected my baseline of 8300 would be.

Something is going on here.. considering it won't even pull stock weights to stock rpm. SLP has their setup dialed in with a stock helix and secondary spring. Should I go back to this ?

Maybe a bad belt? I was going to try my spare today but the deflection was off so much when I put the new belt on.. and on the trail I didn't have the right wrench to adjust.

It Rips up until 7600 or so then pretty much falls on it's face. Looking for some ideas!

Thank you!
Reply With Quote


Rate this post: Yes | No
  #2  
Old 12-31-2018, 03:16 PM
SLP's Avatar
SLP SLP is offline
Currently: Not set.
Join Date: Feb 2010
Location: Idaho Falls, ID
Posts: 93
Thanks: 6
Thanked 264 Times in 52 Posts
Rep Power: 5344833
SLP has a reputation beyond reputeSLP has a reputation beyond reputeSLP has a reputation beyond reputeSLP has a reputation beyond reputeSLP has a reputation beyond reputeSLP has a reputation beyond reputeSLP has a reputation beyond reputeSLP has a reputation beyond reputeSLP has a reputation beyond reputeSLP has a reputation beyond reputeSLP has a reputation beyond repute
Default

Hello mcp. Sorry to see you're having trouble with your sled. We're happy to help you figure it out. The best way to work through this is contacting our tech department.

Please send an email message to Jim Fairchild:

slptech@slp.cc
Reply With Quote


Rate this post: Yes | No
  #3  
Old 12-31-2018, 04:03 PM
Mcp123 Mcp123 is offline
Currently: Not set.
Join Date: Oct 2018
Basic Member
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Mcp123 is an unknown quantity at this point
Default

Quote:
Originally Posted by SLP View Post
Hello mcp. Sorry to see you're having trouble with your sled. We're happy to help you figure it out. The best way to work through this is contacting our tech department.

Please send an email message to Jim Fairchild:

slptech@slp.cc
Thank you! Actually called the tech department today and got some ideas to try. Thanks again.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — What RPMs should I be pulling??? Thread Starter — 009cat Forum — Arctic Cat: 1100 ProClimb Replies — 4 Last Post — 03-01-2013 10:12 AM
Thread — '09 D8 not pulling RPMs Thread Starter — pj8556 Forum — Polaris: IQ Replies — 11 Last Post — 01-24-2012 03:18 AM
Thread — 09 M8 not pulling rpms? Thread Starter — sledhed88 Forum — Arctic Cat: TURBO Replies — 9 Last Post — 01-05-2012 11:02 AM
Thread — 08 m8 not pulling rpms Thread Starter — jlove6 Forum — Arctic Cat: M Series Replies — 4 Last Post — 01-09-2011 11:46 PM
Thread — m7 not pulling rpms Thread Starter — dgreet77 Forum — Arctic Cat Replies — 16 Last Post — 02-14-2009 09:46 PM

All times are GMT -6. The time now is 08:10 PM.












no new posts