For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: TURBO Turbo discussion for Polaris aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 12-04-2018, 11:10 AM
polarisboyc polarisboyc is offline
Currently: Not set.
Join Date: Aug 2009
Location: Utah
Age: 29
Posts: 121
Thanks: 7
Thanked 24 Times in 14 Posts
Rep Power: 0
polarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond repute
Default Proper torque and angle of DET sensor

I've got a 17 Axys having DET issues and have posted about it before. I changed a couple things over the summer and went for a ride last weekend and it threw the code right out of the gate. Only does it when i first get on the throttle or am in and out of the throttle. Someone said the DET sensor needs to be torqued and angled properly. Does anyone know the specs on this? Thanks for the help!
Reply With Quote


Rate this post: Yes | No
  #2  
Old 12-04-2018, 01:53 PM
richracer1's Avatar
richracer1 richracer1 is online now
Currently: Doing the Sidekick Switch
Join Date: Feb 2011
Location: Idaho Falls, ID
Age: 49
Posts: 3,452
Thanks: 287
Thanked 1,690 Times in 981 Posts
Rep Power: 21474848
richracer1 has a reputation beyond reputerichracer1 has a reputation beyond reputerichracer1 has a reputation beyond reputerichracer1 has a reputation beyond reputerichracer1 has a reputation beyond reputerichracer1 has a reputation beyond reputerichracer1 has a reputation beyond reputerichracer1 has a reputation beyond reputerichracer1 has a reputation beyond reputerichracer1 has a reputation beyond reputerichracer1 has a reputation beyond repute
Default

Quote:
Originally Posted by polarisboyc View Post
I've got a 17 Axys having DET issues and have posted about it before. I changed a couple things over the summer and went for a ride last weekend and it threw the code right out of the gate. Only does it when i first get on the throttle or am in and out of the throttle. Someone said the DET sensor needs to be torqued and angled properly. Does anyone know the specs on this? Thanks for the help!

Det Sensor orientation:




From the service manual: Knock Sensor - 168 In-lbs (19 Nm) Install screw clean and Dry.
__________________
Reply With Quote


1 out of 1 members found this post helpful. Rate this post: Yes | No
The Following 2 Users Say Thank You to richracer1 For This Useful Post:
Kenny B (01-03-2019), PaulAnd (12-04-2018)
  #3  
Old 12-04-2018, 02:09 PM
polarisboyc polarisboyc is offline
Currently: Not set.
Join Date: Aug 2009
Location: Utah
Age: 29
Posts: 121
Thanks: 7
Thanked 24 Times in 14 Posts
Rep Power: 0
polarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond reputepolarisboyc has a reputation beyond repute
Default

Perfect, I guess i could have looked in the manual haha. Thanks a bunch I appreciate it!!
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Proper chaincase cover torque for G4? Thread Starter — skank Forum — Ski-Doo: REV Gen 4 Replies — 2 Last Post — 03-02-2017 09:07 AM
Thread — torque specs for head bolts and DET sensor? Thread Starter — pus1100 Forum — Polaris: Pro-Ride Replies — 1 Last Post — 10-27-2011 09:50 AM
Thread — Proper placement of air sensor tube? Thread Starter — flatlandsledder Forum — Arctic Cat: M Series Replies — 4 Last Post — 02-08-2011 03:56 PM
Thread — 05 900, Torque for DET Sensor? Thread Starter — whetsel.m Forum — Polaris: 900 Replies — 1 Last Post — 02-02-2010 02:07 PM
Thread — 2003 Head Det Sensor vs. non-det sensor differences? Thread Starter — snowx22 Forum — Polaris Replies — 1 Last Post — 01-18-2009 12:29 AM

All times are GMT -6. The time now is 03:11 AM.












no new posts