For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: TURBO Turbo discussion for Polaris aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 01-31-2019, 04:19 PM
mk818 mk818 is offline
Currently: Not set.
Join Date: Jan 2018
Location: Kent, WA
Basic Member
Age: 28
Posts: 44
Thanks: 7
Thanked 6 Times in 6 Posts
Rep Power: 0
mk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond repute
Default Axys Silber rectifier/regulator

Has anyone had issues with their rectifier/regulator or stator. The sled currently runs but with all electrical on (hand warmers on hi, brights on) the wires in question start to get hot. The blue headlight light on the dash will flicker on and off turn off at low idle ~1700. rpm. Headlights dim at low idle as well. Thanks!
Attached Images
File Type: jpg 20190131_130934_resized.jpg (192.5 KB, 52 views)
File Type: jpg 20190131_130938_resized.jpg (185.6 KB, 57 views)
Reply With Quote


Rate this post: Yes | No
  #2  
Old 01-31-2019, 05:24 PM
mk818 mk818 is offline
Currently: Not set.
Join Date: Jan 2018
Location: Kent, WA
Basic Member
Age: 28
Posts: 44
Thanks: 7
Thanked 6 Times in 6 Posts
Rep Power: 0
mk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond repute
Default Solved!

I think i found the answer in another thread. If anyone can confirm this is chassis electrical? If so i am comfortable with removing and soldering. If not I want to find the core to this problem.

https://www.snowest.com/forum/showth...ight=regulator
Reply With Quote


Rate this post: Yes | No
  #3  
Old 01-31-2019, 06:55 PM
willjogervais willjogervais is offline
Currently: Not set.
Join Date: Mar 2011
Location: SW Minnesota
Age: 39
Posts: 432
Thanks: 184
Thanked 154 Times in 84 Posts
Rep Power: 15803047
willjogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond repute
Default

On my 16' my headlight would never run on bright at idle. I always chalked it up to low voltage from the starter. It was like that since new. Never had a problem but I didnt check the wiring to see if it was warm either.
Reply With Quote


Rate this post: Yes | No
  #4  
Old 01-31-2019, 07:23 PM
mk818 mk818 is offline
Currently: Not set.
Join Date: Jan 2018
Location: Kent, WA
Basic Member
Age: 28
Posts: 44
Thanks: 7
Thanked 6 Times in 6 Posts
Rep Power: 0
mk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond reputemk818 has a reputation beyond repute
Default

Yeah I was only concerned because it melted my connector
Reply With Quote


Rate this post: Yes | No
  #5  
Old 01-31-2019, 08:23 PM
Sheetmetalfab's Avatar
Sheetmetalfab Sheetmetalfab is online now
Currently: Boost is addictive
Join Date: Oct 2010
Location: Ak
Age: 33
Posts: 4,844
Thanks: 2,792
Thanked 1,615 Times in 1,018 Posts
Rep Power: 21474849
Sheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond repute
Default

Quote:
Originally Posted by willjogervais View Post
On my 16' my headlight would never run on bright at idle. I always chalked it up to low voltage from the starter. It was like that since new. Never had a problem but I didnt check the wiring to see if it was warm either.
That’s done on purpose to preserve power to the oil pump at idle.
__________________
Try again
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to Sheetmetalfab For This Useful Post:
mk818 (01-31-2019)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Silber Axys keeps detonating Thread Starter — polarisboyc Forum — Polaris: TURBO Replies — 33 Last Post — 03-08-2018 06:32 PM
Thread — Why would you not have a Silber turbo axys? Thread Starter — Wheel House Motorsports Forum — Polaris: TURBO Replies — 32 Last Post — 12-01-2017 08:41 PM
Thread — Axys Silber Intercooler Thread Starter — doudea Forum — Polaris: TURBO Replies — 21 Last Post — 01-28-2017 12:12 AM
Thread — 1989 Ski-Doo Safari Cheyenne Voltage Regulator/Rectifier Problem Thread Starter — 66hockey99 Forum — Ski-Doo: S-2000 and older Replies — 3 Last Post — 11-06-2014 11:44 PM
Thread — Need m-series regulator/rectifier Thread Starter — egesledder Forum — Colorado Replies — 0 Last Post — 01-03-2014 07:29 AM

All times are GMT -6. The time now is 05:26 AM.




no new posts