For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Reply
 
Share Thread Tools Display Modes
  #1  
Old 01-27-2019, 10:46 AM
TFOdin TFOdin is offline
Currently: Not set.
Join Date: Jan 2019
Basic Member
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
TFOdin is an unknown quantity at this point
Default 2009 Polaris Dragon 800

Hi everybody,
I have a Polaris Dragon 800 with some issues:
-Requires a bit of throttle for starting
-Will idle sometimes, sometimes not
-Dies when I give a slight tug on throttle cable on handlebars
Anybody else out there with similar issues/solutions?
Reply With Quote


Rate this post: Yes | No
  #2  
Old 01-27-2019, 10:18 PM
Skylane1978 Skylane1978 is online now
Currently: Not set.
Join Date: Dec 2008
Age: 40
Posts: 4
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 0
Skylane1978 has a reputation beyond reputeSkylane1978 has a reputation beyond reputeSkylane1978 has a reputation beyond reputeSkylane1978 has a reputation beyond reputeSkylane1978 has a reputation beyond reputeSkylane1978 has a reputation beyond reputeSkylane1978 has a reputation beyond reputeSkylane1978 has a reputation beyond reputeSkylane1978 has a reputation beyond reputeSkylane1978 has a reputation beyond reputeSkylane1978 has a reputation beyond repute
Default

Sound so like throttle safety switch issues. Check throttle cable adjustment, should be able to search forums for info on that process. Bypass the switch to test, but I wouldn’t ride with the TSS disabled without a tether.

Good luck!
Reply With Quote


Rate this post: Yes | No
  #3  
Old 01-29-2019, 10:37 AM
sled_guy's Avatar
sled_guy sled_guy is offline
Currently: In limbo
Join Date: Jul 2001
Location: Riverton, Utah
Posts: 3,557
Thanks: 0
Thanked 617 Times in 413 Posts
Rep Power: 21474857
sled_guy has a reputation beyond reputesled_guy has a reputation beyond reputesled_guy has a reputation beyond reputesled_guy has a reputation beyond reputesled_guy has a reputation beyond reputesled_guy has a reputation beyond reputesled_guy has a reputation beyond reputesled_guy has a reputation beyond reputesled_guy has a reputation beyond reputesled_guy has a reputation beyond reputesled_guy has a reputation beyond repute
Default

Sounds like the throttle adjust screw on the throttle body is tightened up but the slack isn't out of the cable, dead man switch is activating. If memory serves there is an inline adjuster in the cable a little ways from the throttle block. You can use it to take slack out of the cable.

sled_guy
__________________
"Sorry, I thought you could ride"
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 2009 polaris dragon 800 Thread Starter — leelang197@hotmail.com Forum — Polaris Replies — 0 Last Post — 01-11-2017 01:04 PM
Thread — 2009 Polaris 800 Dragon Thread Starter — THRILL_SEEKER Forum — Polaris (Swapmeet) Replies — 11 Last Post — 12-23-2014 05:20 PM
Thread — 2009 polaris 800 dragon sp s,mn Thread Starter — dragonguy Forum — Polaris (Swapmeet) Replies — 1 Last Post — 08-23-2011 11:08 AM
Thread — 2009 Polaris 800 Dragon Thread Starter — sledneck700 Forum — Polaris (Swapmeet) Replies — 1 Last Post — 11-16-2010 11:11 PM
Thread — 2009 Polaris RMK Dragon 800 Thread Starter — Sledneck9 Forum — Polaris (Swapmeet) Replies — 7 Last Post — 09-05-2009 07:32 PM

All times are GMT -6. The time now is 12:58 PM.








no new posts