For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: IQ 2005-Current, all models in the IQ and IQ Raw chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 02-09-2015, 07:05 PM
dragon800nick dragon800nick is offline
Currently: Not set.
Join Date: Feb 2015
Basic Member
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
dragon800nick is an unknown quantity at this point
Default 09 polaris dragon 800 going into limp mode.

My 09 polaris dragon 800 keeps going into limp mode. What it will do is the cel light will come on around 6800-7000 rpm. It will come on a couple of times then go into limp mode. I have tried messing with the ethanol wires but didn't make a difference. I always run shell 91 fuel with no ethanol. What would happen if I have the wires plugged in and running ethanol free fuel. This would theoretically stop the sled from going into limp mode? The limp mode is caused from it running to lean? Or could there be something wrong with detonation sensor? I'm not suRe wat to do next. Thanks for any help in advance!!
Reply With Quote


Rate this post: Yes | No
  #2  
Old 02-09-2015, 07:39 PM
retiredpop retiredpop is offline
Currently: Not set
Join Date: Jul 2001
Location: Calgary
Posts: 1,076
Thanks: 97
Thanked 190 Times in 171 Posts
Rep Power: 8946981
retiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond repute
Default

You should have them plugged together when you are running non ethanol fuel. Unplugging them will richen the fuel mixture so you might prevent detonation by unplugging them. Do you have a full tank of fresh fuel in your sled? Old fuel even with stabilizer will cause detonation.
__________________
The older I get the better I was. In fact now that I think about it I'm a legend!

Haven't outgrown my 600 yet!
Reply With Quote


Rate this post: Yes | No
  #3  
Old 03-01-2015, 09:50 PM
RMK4u2 RMK4u2 is offline
Currently: Selling parts
Join Date: Dec 2007
Location: Devils Lake, ND
Posts: 24
Thanks: 5
Thanked 1 Time in 1 Post
Rep Power: 0
RMK4u2 has a reputation beyond reputeRMK4u2 has a reputation beyond reputeRMK4u2 has a reputation beyond reputeRMK4u2 has a reputation beyond reputeRMK4u2 has a reputation beyond reputeRMK4u2 has a reputation beyond reputeRMK4u2 has a reputation beyond reputeRMK4u2 has a reputation beyond reputeRMK4u2 has a reputation beyond reputeRMK4u2 has a reputation beyond reputeRMK4u2 has a reputation beyond repute
Default

That happened to mine as well and I was told it was the voltage regulator.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Egt sensor cause limp mode 09 800 dragon Thread Starter — Stngllhm Forum — Polaris: IQ Replies — 6 Last Post — 02-23-2015 07:08 AM
Thread — 2009 Dragon issues. LIMP MODE! Thread Starter — DunmoreCowboy Forum — Polaris Replies — 0 Last Post — 03-24-2014 06:16 PM
Thread — Help... 09 dragon 800 goes in limp mode? Thread Starter — Jayxcr Forum — Polaris: IQ Replies — 15 Last Post — 01-04-2013 07:36 PM
Thread — Is there a failsafe mode(limp mode) on Nytro if overheat going down the trail? Thread Starter — snowmanx Forum — Yamaha: 4-Stroke Replies — 9 Last Post — 01-04-2012 08:20 PM
Thread — 900 limp mode help please!! Thread Starter — jlloyd Forum — Polaris: 900 Replies — 9 Last Post — 02-12-2010 10:17 AM

All times are GMT -6. The time now is 10:18 PM.

no new posts