For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Reply
 
Share Thread Tools Display Modes
  #1  
Old 02-02-2019, 08:19 PM
KennyBMO KennyBMO is offline
Currently: Not set.
Join Date: Feb 2019
Basic Member
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
KennyBMO is an unknown quantity at this point
Default Electrical Issues 2015 600 Etec

Good evening. Trying to get my sled back on the snow, but having issues. The sled is an electric start and cranks fine, but no lights, dash, or start. Friend brought over Candoopro and we got a code of P0608. So, I looked that up and it says: P0608 is bad wires/shorted TPS or ERave position sensor. To me that says it has to be bad wires, because the other 2 wouldn't cause no power to cluster correct? Wondering if the ECU is fried? Kinda stumped on where to start. Thanks for the help in advance.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 02-03-2019, 12:45 PM
KennyBMO KennyBMO is offline
Currently: Not set.
Join Date: Feb 2019
Basic Member
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
KennyBMO is an unknown quantity at this point
Default Another quick question

Does a bad ECU or ECC have a fault code? Thanks again
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Tags
600, ecu, etec, skidoo

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 2015 Summit SP 146 600 Etec Black Jackson, WY Thread Starter — SUMMERSUX77 Forum — Ski-Doo (Swapmeet) Replies — 1 Last Post — 12-17-2017 05:13 PM
Thread — 2015 etec 600 reflash issues Thread Starter — nytro4 Forum — Ski-Doo: XM Sleds Replies — 0 Last Post — 03-04-2016 05:44 AM
Thread — 2015 etec 600 reflash problems Thread Starter — nytro4 Forum — Ski-Doo Replies — 1 Last Post — 02-08-2016 04:38 PM
Thread — 2015 600 Etec motor 850 miles $2k Thread Starter — Wheel House Motorsports Forum — Engine/Engine Parts (Swapmeet) Replies — 0 Last Post — 01-25-2016 07:27 PM
Thread — 2015 Electrical issues... Thread Starter — DusterB Forum — Arctic Cat: Proclimb M Replies — 2 Last Post — 01-14-2016 10:28 PM

All times are GMT -6. The time now is 02:06 PM.








no new posts