For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Reply
 
Share Thread Tools Display Modes
  #1  
Old 12-29-2018, 07:12 PM
sledheadxm sledheadxm is offline
Currently: Not set.
Join Date: Jan 2015
Basic Member
Posts: 40
Thanks: 7
Thanked 7 Times in 4 Posts
Rep Power: 0
sledheadxm has a reputation beyond reputesledheadxm has a reputation beyond reputesledheadxm has a reputation beyond reputesledheadxm has a reputation beyond reputesledheadxm has a reputation beyond reputesledheadxm has a reputation beyond reputesledheadxm has a reputation beyond reputesledheadxm has a reputation beyond reputesledheadxm has a reputation beyond reputesledheadxm has a reputation beyond reputesledheadxm has a reputation beyond repute
Default 900 ACE “push to start” and check engine llight

Wife’s 2014 900 ace renegade has an intermittent issue where it the sled slows to idle and won’t move with “push to start” showing in the display and check engine light on. It idles fine when it does this however won’t rev up. If you leave if off for a bit it always cleared sometimes quickly sometimes it takes a bit longer. Anyone experienced this before? Thanks in advance!!
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 13 e start HID conversion check engine light on Thread Starter — yammyman_1 Forum — Ski-Doo: XM Sleds Replies — 0 Last Post — 01-06-2014 01:12 PM
Thread — 2005 Fusion 900 Check Engine Light Thread Starter — GED Forum — Polaris: 900 Replies — 2 Last Post — 12-29-2010 08:59 AM
Thread — 900 check engine light???? Thread Starter — bostonwhaler Forum — Polaris: 900 Replies — 8 Last Post — 02-09-2010 08:40 PM
Thread — 900 check engine code Thread Starter — richruss Forum — Polaris Replies — 2 Last Post — 03-04-2009 11:57 PM
Thread — 05 900 Check engine light Thread Starter — SLEDWRENCHER Forum — Polaris Replies — 3 Last Post — 02-13-2009 02:30 PM

All times are GMT -6. The time now is 01:59 PM.








no new posts